View Full Version : Nexus 7 Episode sync issue

12-27-2013, 09:35 AM
Nexus 7
Android 4.4.2 build KOT49H

Sync logs show that it is starting the execution of the upload syncing request, but the next line of the log just says "Sync failed! null".

Any ideas? Please let me know if there is any other information I need to provide.

12-27-2013, 10:28 AM

I would fist try to log out from the sync and re-log back in (Menu > More > Settings > Episode Sync) as this may fix the issue.

If this does not help. There is another log file that you can take a look - located in Menu > More > Settings > Menu (press menu key again) > View Logs > View Android Log.

Try to trigger a sync (for example play/pause an episode, wait for 10 second for the sync to complete and then look at the log file) - it should have a more detailed progress report with (hopefully) better explanation of what is going wrong.


12-27-2013, 10:33 AM
I tried the log out/log is and even went so far as to uninstall and reinstall the application. The Android log seems to be pointing to some kind of null pointer exception. I emailed the log file to support along with my user name so it can be tied to this thread. Hopefully it will help.

12-27-2013, 10:50 AM
Thanks for the log file.

From what I can tell, there is something wired in the description in one of the episodes that is being synced (I think it is "Brew Strong - Attenuation paused").
What feed (feed URL) is this episode from? Hopefully we can find a way to reproduce the issue on one of our devices.


12-27-2013, 10:55 AM

I have the same set of podcasts on my Galaxy S4 and it appears to sync without issue. The phone is running 4.3 build JSS15J. The issue appears isolated the Nexus 7 or the 4.4 Android version.

12-27-2013, 11:10 AM
Yes, very strange - I could not replicate it either. Would you be able to send (to our support e-mail) a BeyondPod backup (Menu > More > Settings > Backup and Restore > Backup) from your Nexus 7 device - there may be something in the settings or other feeds/episodes that triggers the problem. I can then try restoring on an identical N7 - hopefully it will trigger the same problem.


12-27-2013, 11:13 AM
Just sent it.

12-27-2013, 07:44 PM
Thanks for the backup,

I was not able to exactly replicate the issue, (as for me it worked correctly) but based on what was in the log you sent earlier, I was able to do a "scientific guess" ;) to what may be going on.

Can you please try one of the builds linked below on your Nexus 7 and see if fixes the issue.

Phone: http://www.beyondpod.mobi/android/beta/downloadbeta.aspx?v=3.2.61
Tablet: http://www.beyondpod.mobi/android/beta/downloadbeta.aspx?v=3.20.61


12-30-2013, 01:15 PM
That appears to have worked! Thanks so much for your help!