PDA

View Full Version : Android device disconnects randomly from Chromecast



trainedseal
01-29-2014, 08:44 PM
When casting from Beyondpod, my feed stops at random - I haven't been able to see any correlation with what is happening on my phone (email alerts, plugging/unplugging, sleep, etc). When it happens the TV display says "Your Android device has disconnected." This doesn't happen with any other Chromecast apps on my phone (I use Netflix, Youtube and Songza). My phone is an HTC Incredible S - not exactly state of the art but it does the job.

juwlz
01-30-2014, 08:23 AM
Hi, and welcome to the forum.

To troubleshoot this, could you please get an Android log immediately after a disconnection. It may or may not have any useful information in it, but there's no way to know without capturing it.

Next time you get a disconnection:

Use Menu | More... | Settings | Menu (again) | View Logs | Android log
From the Menu, choose Email Support
Include in the text of your email what happened, and a link / reference to this thread, with your forum user name.

Julie

SethMpls
02-04-2014, 02:10 AM
This is continually happening to me as well. I've experienced it on 2 devices, HTC Rezound and HTC ONE. I'm sending a log now. If there is an easy fix in the Menu Settings, please post.

trainedseal
02-04-2014, 10:18 AM
Update: I don't have a fix, but I have found a work-around for this problem. I have found that the disconnecting doesn't happen if my phone does not go to sleep, so I have set my phone to stay awake when charging and I use BeyondPod only with my phone plugged in. Not a great solution, but it does seem to have cured the problem (so far).

juwlz
02-06-2014, 09:18 AM
Unfortunately, the connection and disconnection is handled entirely by Google and the Chromecast side. All BeyondPod can do is request and respond to connections.

Hopefully the new ChromeCast SDK (which will be available to you when you get your next Play Services update - rolling out now ... but probably slowly if past experience is anything to go by) will improve connection robustness.

foge
03-18-2014, 09:30 PM
This happens to me as well. Just downloaded the app, super excited to stream my podcasts via chromecast but alas it constantly disconnects and I have to force stop the beyondpod app to get the cast icon to appear again. All other casting supported apps work great, like Netflix and YouTube. This has to be something you guys can fix. Maybe Netflix doesn't let the phone sleep or something, but I find that unlikely.

Running on a Nexus 5 with all the latest updates. Any help would be much appreciated.

juwlz
03-19-2014, 02:38 AM
Hi, and welcome to the forum.

Does this happen with all feeds?
Do you get the same problem when playing the same episodes with Google Music?

Which latest updates? (What version of BeyondPod are you running? Menu | More... | About BeyondPod.)

Julie

foge
03-19-2014, 12:42 PM
Thanks for the response.

It has happened with the two feeds that I have tried.
I have not tried playing the episodes with Google Music yet but I will try that later this afternoon and let you know.
I am able to cast all my music with Google Music just fine and without interruptions, i just haven't tried the podcasts yet.

Running BeyondPod 3.3.68
Nexus 5 running Android 4.4.2

Everything seems to play fine for about 5-10 minutes or so, then the episode stops playing, the chromecast screen on the tv goes back to the default screen when no apps are connected, and the beyondpod app no longer shows the casting icon and will only play through the device until force stopping the app and restarting it.

juwlz
03-20-2014, 11:49 AM
You can exit BeyondPod cleanly using Menu | More... | Exit - you shouldn't need to Force Close it.

It sounds as though the ChromeCast is losing the connection back to BeyondPod (unfortunately, the error handling is sparse, to say the least - if the connection gets dropped, there's nothing to tell the sending apps that it's happened).

Having said that, ChromeCast should just keep playing, even without a connection to BeyondPod - I've actually rebooted my phone when casting before now. It makes absolutely no difference to the ChromeCast playback whatsoever, except that BeyondPod no longer remembers that it's casting. The ChromeCast handles all the data traffic and keeps playing, even without a connection to the sending app. Once the sending app has sent a request to the ChromeCast to play a particular file, the sending phone/tablet is only there to provide a remote control, and to accept status updates (progress reports and end of playing) back from the ChromeCast.

My guess is that the server for the two podcasts that you're playing may be struggling to keep the connection with the ChromeCast player.

The difference between BeyondPod and most other casting apps is that the other apps have complete control over both ends (e.g. Google Music, Google Play, Netflix etc. all control the content servers as well as the app). BeyondPod, on the other hand, can play content from any site with an RSS feed, and has no control over how the publishers' servers are configured. Many of them don't handle streaming particularly well (and ChromeCast is streaming the content direct from their sites, not playing the local content on your device, even if you have downloaded it there for playing without the ChromeCast).

Assuming your podcasts have been downloaded, can you delete one of the episodes in question, and stream on your phone without using ChromeCast? And if so, can you pause (for 5-10 minutes) and then resume where you left off, or does the podcast start at the beginning again when you're streaming? If it starts at the beginning, that's an indication that the server isn't capable of responding to BeyondPod's request to start playback at a particular point in the file.

What are the URLs of the feeds you're having problems with? (If you edit the feed, the URL is the first field that you see, so you can easily copy and paste it.)

Julie

foge
03-20-2014, 04:11 PM
All of that makes perfect sense. Everything I've tried listening to has been downloaded on my device. I haven't tried straight streaming on the device to see if it cuts out like it does with the chromecast. One of the feeds I was having problems with was http://feeds.feedburner.com/AceOnTheHouse.

Like I said I just downloaded this the other day and was super excited about it but I haven't had a chance to really add more than 3 feeds and the two I've been listening to are from the same host it seems. It very well could be an issue with the chromecast connection to the host, which is disappointing since I listen to these podcasts quite a bit. I'll update if I discover anything further that seems to point toward the app, but after reading your description of how your app works I'm pretty convinced that this isn't your issue. Thanks for your time and I'll let you know if anything changes.

juwlz
03-25-2014, 03:32 AM
Actually, I've seen some random Chromecast disconnects myself on feeds that shouldn't have a problem.

My logs revealed a bug in the handshaking in BeyondPod. Keep an eye out for the next beta version, which will hopefully fix this.

Julie

cjblack87
01-04-2015, 11:55 PM
Hi, I just downloaded the unlock key and am having the same disconnect issue with chromecast. I see most of these posts were from about a year ago... Any resolution?
I was not having any issues with the podcast during normal streaming playback. And, my other apps are working normally when I cast them. I am also having an intermittent issue where the chromecast option will not be shown when I'm in beyond pod. I can close out of beyond pod and go back in and it will show up. Not sure if that could be related.

Ev_
01-23-2017, 05:55 AM
In case anyone is googling for a solution to this, I think I've found an answer.

Over the last year or so I've been suffering from my phone regularly becoming disconnected from my Chromecast. This has happened with two different Chromecasts (a 1 and a 2), with two different Android phones from different brands, and with two different routers from different brands.

I've got good Wi-Fi strength where my Chromecast is located (other devices have shown a solid 8Mbps in the same spot) and an even stronger signal where my phone lives. But still the disconnects continued.

I tried every possible router tweak suggestion that I could find on the web. On my phone I've checked countless Android settings, reinstalled various apps and cleared caches for them all. Yet still problems...

So, the answer? Give up on Chromecast. Seriously. It clearly has a fundamental flaw that affects some owners for some unknown reason, but which can't be fixed by the end user. If it could, someone would have posted a cure online somewhere by now. It's just not worth the frustration and the wasted hours trying to resolve a "bad" Chromecast situation.

So get your Chromecast on eBay, get some of your money back, and spend an extra $20 or so to buy something that actually works. I opted for a Roku Streaming Stick, and not only does it work perfectly, all of the time, it actually gives a better user experience than a fully functioning Chromecast, whether using the accompanying remote control or the Roku app on my phone. Win-win.

I'd urge you to do the same. You won't regret it.

kristinbarker
05-29-2017, 11:18 AM
Hi Friends,

Just to add some information as I too am experiencing this issue. I did an A/B test on this with two versions of Chromecast (original and updated), comparing the consistency of BeyondPod to Podcast Addict using the same podcast episode. That means the same file was being used in all four permutations.

With both versions of Chromecast, Beyondpod disconnected in less than four minutes of playback whereas Podcast Addict, with either version of Chromecast, never once disconnected and successfully played through the end of the 45:00 audio file.

So blaming Chromecast for the issue simply doesn't bear out. This is an issue with Beyondpod. I'm a big fan of the interface and would like to keep using it, but given my reliance on Chromecast to playback episodes over my sound system, it's currently unusable.

I hope to see a fix here soon.

Thanks!
Kristin

phalkon30
06-13-2018, 02:41 PM
I've been continuing to test issues with CC disconnecting, I find they mainly happen when I'm on weak signal or when my phone goes idle.

As a workaround I'm now casting the entire device through the system toggle, or through the Home app. That way any audio or video on the device gets routed to the CC. I have yet to have a dropped session, and it reacts much faster to play/pause commands.

I may try disabling Doze for BeyondPod, but at this point it's working for me to NOT use the built in ChromeCast button and just cast my entire system.