View Full Version : Couldn't play video with internal player

02-13-2014, 09:04 AM
This morning I was cruising through my smartplay playlist when all of a sudden everything came to a stop. BP couldn't play a video with the internal player. I actually get that quite a lot, but today I decided to troubleshoot. I am using BP Android for tablets ver 3.20.59. And the feed I am working with is
The video I was trying to play was in my smartplay playlist, from Jan 22nd, titled "G-FOLD Diversion Test".
Sure enough, when I try to play this video with the internal player from the smartplay playlist tab, I get the "cannot play video error". I then went to the feed directly and went to that video. I noticed that it did not have the orange thumbtack, therefore indicating that the video had not been downloaded, which is strange because it was in the playlist. When I tapped on the video, the video did start to stream and played correctly. Other videos from the feed that have the orange thumbtack filled in also play correctly.

One other troubleshooting step I took was to try playing it with the external player (MX player), and that did not work either.

What do you think was going on here? Do I not understand correctly how the playlist works and what the orange thumbtack indicates? I really want to stick with the internal player if possible.

02-13-2014, 09:13 AM
The orange thumbtack shows that you've downloaded the episode. If it's grey, you haven't.

What settings do you have for that feed? My guess is that you have it set to stream, rather than download. Streaming episodes can be on your playlist. (Although your settings for when to stream may prevent it from playing - Menu | More... | Settings | Player Settings | Streaming preferences can be Always / WiFi only / Never).


02-13-2014, 09:38 AM
Feed settings are as follows:
Feed category is smartplay playlist
Feed podcast episodes is "download latest 3 episodes"
Episode cleanup is "keep at most 10 local episodes" and "delete episodes older than 180 days"

I don't want to stream any episodes at all. I did go into player settings and allow streaming was set to "always". I now have it set to Never.