View Full Version : No casting icon after purchasing unlock key

04-29-2014, 09:40 PM
I just purchased and installed unlock key, but still have no chromecast icon. YouTube works fine. I am using a Samsung Galaxy Tab 10.1 with Android 4.0.4. I have restarted apps, Chromecast, and tablet, buts still no connection to Chromecast. Any suggestions?

04-30-2014, 02:27 AM
Hi, and welcome to the forum.

Do you definitely have the unlock app installed? (https://play.google.com/store/apps/details?id=mobi.beyondpod.unlockkey)

04-30-2014, 07:52 AM
Yes it is listed in my installed applications.

04-30-2014, 10:19 AM
Actually, on further investigation, if you have the correct version of BeyondPod and Google Play services, the cast icon should show up anyway. If you haven't purchased the unlock key, you'll get a message to say that you need to purchase the key to be able to cast.

For it to work you need to have:

BeyondPod version 3.3.68 or later, AND
Google Play services 4.3.25 or later - if you need to update it, here's the link https://play.google.com/store/apps/details?id=com.google.android.gms

If you have both of these, try toggling WiFi off and back on again.


04-30-2014, 11:24 AM
Thanks for the replies. I had tried all the suggestions before (including toggling wifi) with no success. I went in today and turned tv on, opened up BeyondPod and lo and behold the casting icon was there. I tried it and it worked with the videos I tried. I don't know what is going on, but for now it is working.

Thanks again,

09-11-2015, 06:17 AM
ahh ok, both were set via autotimer but only one shows the icon?

05-08-2019, 03:48 AM
Which unlock app you are using nowadays? Is mi account unlock tool (http://www.crunchytricks.com/2018/05/download-mi-account-unlock-tool.html) is good or not?

05-08-2019, 08:04 AM
Which unlock app you are using nowadays?

To use the Unlock Key, you must have purchased and downloaded the "BeyondPod Unlock Key" from the Google Play Store.

08-08-2019, 03:00 PM
you have too many items to show.... They need space for the pics, that would be my first thought, try disableing a few and see if the pics show up