PDA

View Full Version : Some podcast feeds not showing images after latest restore



urbster1
01-14-2016, 03:59 PM
I restored my latest backup and some of the episodes were lost due to SD card changes, which is not a big deal to me, but now a bunch of feeds aren't showing images anymore. I've updated them, tried selecting custom images and then deleting them, as well as refreshing image caches. Nothing seems to work. What should I try next?
I am on the HTC One M9 running Marshmallow 6.0.
654

juwlz
01-15-2016, 06:16 AM
When you say SD card changes, did you have the epsiodes on a removable SD card on both old and new phone? If not, did you back up the BeyondPod folder as well as the settings?

I note in your screenshot that the two without artwork are not (yet) downloaded. Did things change after downloading them?

Julie

urbster1
01-15-2016, 06:57 AM
Hi Julie!
I didn't back up the BeyondPod folder, just the settings. Actually I didn't need any of the episodes that I had previously downloaded, I just wanted to retain the list of all the podcasts I'm subscribed to.

I downloaded the 2 podcasts above. One of the episodes started showing an image, but the podcast feed still doesn't show an image. The other doesn't show an image at all.

655656657

juwlz
01-15-2016, 09:54 AM
Bp retrieves images from one of two places:
1. The link in the feed
2. The episode file itself

BP downloads images from the feed when the feed gets updated. If you run a full update of all your feeds you should download the missing images (if the feed actually still has a live image for the episode - I have seen many feeds that used to have an image and then the image link points to nowhere).

Once an episode has been downloaded, BP can get the image from the file directly. That, combined with the potential for missing images in the feed described above, may be why you're seeing some images, but not all.


If the feed does not have image, you can also set the image manually in the feed properties to any image he likes.



There is a way to force feed to refresh everything for a the feed (image and content) Open the feed > Switch to All Published > Tap on \/ in the header to expand it and long press on the Gear icon. This will clean all caches and refresh the feed and image. I don't remember when that was added, but a think it was a few versions ago (that could be Beta versions, not released versions!).

HTH
Julie

urbster1
01-15-2016, 10:14 AM
That works! I'll just refresh the feeds with missing images. Thanks again Julie!