PDA

View Full Version : 4.2.19: Completely broken on Android 8.1



wugazi
12-05-2017, 05:16 PM
Hello. Awhile back, I upgraded to 4.2.19 when I was on 8.0 (Pixel XL). Before that (4.2.14, i think?), I was happy. A quirk here or there but the program worked pretty well. 4.2.19 caused the lock screen controls to disappear, and the widget didn't work most of the time. That was annoying enough. Now, with Android 8.1, 4.2.19 is just plain broken. The widget is flat out broken. I can start BeyondPod manually, and even start a podcast inside it, but I can't control anything at that point. The program just freezes up in general. The only way to stop what's playing is to force close the app or reboot Android. This is completely unacceptable. Has anyone else run into this problem? I'm guessing there are no workarounds, just the wait for a new version that'll hopefully have proper 8.0 support and actual 8.1 support.

Thanks.

phalkon30
12-06-2017, 04:58 PM
I had the same issue on 8.1, your best option is to start over with the .18 beta. That version is still working flawlessly, frankly I still don't understand why they refuse to roll back to it.

wugazi
12-06-2017, 05:14 PM
I had the same issue on 8.1, your best option is to start over with the .18 beta. That version is still working flawlessly, frankly I still don't understand why they refuse to roll back to it.

Thanks. I had that thought this morning and rolled it back. Lost my feeds (uggh) but at least the rest that I was using regularly is working again. Now I just need to figure out how to get the Play Store to stop trying to get me to upgrade to 4.2.19!

ratatosk
12-06-2017, 05:17 PM
Thanks. I had that thought this morning and rolled it back. Lost my feeds (uggh) but at least the rest that I was using regularly is working again. Now I just need to figure out how to get the Play Store to stop trying to get me to upgrade to 4.2.19!

I'm almost certain that someone in the Forum had a solution for that, maybe somewhere in the longest thread ranting against 4.2.19. Sorry, I don't remember what it is - I have 8.0, so I'm one of the suckers holding out hope for a new beta before Christmas.

phalkon30
12-06-2017, 05:21 PM
Thanks. I had that thought this morning and rolled it back. Lost my feeds (uggh) but at least the rest that I was using regularly is working again. Now I just need to figure out how to get the Play Store to stop trying to get me to upgrade to 4.2.19!

Unfortunately I painfully lost it all too. Had lots of podcasts that are no longer available for download that are all gone (like back episodes of car talk)

I removed myself from the beta in the play store, then manually installed the beta APK from the BeyondPod website. Maybe you can get away with not being updated by removing yourself from the beta? I think that way you'll have a higher version than the current non-beta track (.14)

If you need the manual APK it's here: http://www.beyondpod.mobi/Android/BETA/betachanges.htm

phalkon30
12-06-2017, 05:29 PM
http://www.beyondpod.com/forum/showthread.php?4298-4-2-19-a-disastrous-release-Let-me-count-the-ways&p=17830&viewfull=1#post17830

I think this is what you're talking about. Not exactly straight forward or easy. This is a process they really should work on...

(sorry, it didn't quote ratatosk for some reason).

ratatosk
12-07-2017, 12:40 AM
Unfortunately I painfully lost it all too. Had lots of podcasts that are no longer available for download that are all gone (like back episodes of car talk)

I removed myself from the beta in the play store, then manually installed the beta APK from the BeyondPod website. Maybe you can get away with not being updated by removing yourself from the beta? I think that way you'll have a higher version than the current non-beta track (.14)

If you need the manual APK it's here: http://www.beyondpod.mobi/Android/BETA/betachanges.htm

Ouch. That's a big reason I haven't switched back to 4.2.18.
That said, for future reference, with a file explorer you can go in manually and copy all those downloaded episodes to another location, then switch, then put them back in. When I've done that in the past, it has messed with things like time-stamps (they were all listed as having been published on the date of the cut and paste), so unless I pay close attention to the filenames the puzzlers in my old CarTalks are all out of order, but the episodes still showed up in My Episodes after I put them back in there. And since that doesn't depend on the functionality of the Beyondpod software, it should work in a pinch with rolling back from 4.2.19 to 4.2.18. But you do lose all the information about what has and hasn't been played, which, when you're as complicatedly backlogged in long feeds like In Our Time as I am, is a real pain to recreate by hand (took hours).

ratatosk
12-07-2017, 12:51 AM
http://www.beyondpod.com/forum/showthread.php?4298-4-2-19-a-disastrous-release-Let-me-count-the-ways&p=17830&viewfull=1#post17830

I think this is what you're talking about. Not exactly straight forward or easy. This is a process they really should work on...

(sorry, it didn't quote ratatosk for some reason).

(If this shows up as a double, I apologize.)

Ouch. Yeah, losing all that information is one big reason I haven't switched back to 4.2.18.
That said, for future reference, or for other people attempting this, if you go in with a file explorer of some sort you can copy all the episodes you're worried about losing to some other directory. Then, after Beyondpod is back up and running the way you want, you can cut and paste those files back into the appropriate folder. When I've done this in the past, it's messed up the time-stamps (Beyondpod thinks they all showed up at the same time), so my puzzlers are all out of order unless I were to put more effort into finding the next episode than I'm willing to put in. But at least the pasted episodes did show up in My Episodes. Also, since this just uses some third-party file explorer, it doesn't rely on Beyondpod, so it should be possible to save those old episodes even with a badly broken 4.2.19.

For me, a bigger problem is the loss of information about which episodes I have and haven't listened to - when you're as complicatedly backlogged in an old feed like In Our Time as I am, that's an incredible pain to recreate by hand.

chassum
12-08-2017, 07:27 AM
4.2.19 was working (mostly) for me when I was on 8.0, but when I upgraded to 8.1 BP totally borked. I'm really reluctant to roll back and possibly have to re-do all my feeds (I have a lot of feeds and complex smart playlists...) It would be great if Beyond Pod dev team could give some ETA on the next beta...

KimW
12-12-2017, 10:06 AM
4.2.19 was working (mostly) for me when I was on 8.0, but when I upgraded to 8.1 BP totally borked. I'm really reluctant to roll back and possibly have to re-do all my feeds (I have a lot of feeds and complex smart playlists...) It would be great if Beyond Pod dev team could give some ETA on the next beta...

Hello, I have reported issues coming in about the app breaking with 8.1v. Unfortunately I do not have an ETA on the next beta release from the development team but I will keep you updated as soon as I know more. I do know they are actively fixing bugs and want to have all of the bugs that have been reported, fixed and tested before pushing another release. They have added more developers and testers to the team to try and get this done faster for everyone.

Golbez
12-12-2017, 12:21 PM
Hello, I have reported issues coming in about the app breaking with 8.1v. Unfortunately I do not have an ETA on the next beta release from the development team but I will keep you updated as soon as I know more. I do know they are actively fixing bugs and want to have all of the bugs that have been reported, fixed and tested before pushing another release. They have added more developers and testers to the team to try and get this done faster for everyone.

Have they given a reason why the current broken beta is still available for download?

KimW
12-13-2017, 10:15 AM
Have they given a reason why the current broken beta is still available for download?

I only know that the decision was made to keep the release out and to fix the bugs instead of rolling back. I wish I had a better answer for you. I am trying to advocate for the users and get fixes pushed asap. I apologize for the inconvenience!

colin_young
12-13-2017, 10:38 AM
Broken on 8.1 here also.

* no controls in notification bar (that's been going on since beta 19 even on 8.0)
* frequent (as in every 30 seconds or so) "BeyondPod is not responding" message, however audio playback continues without issue, but my position in the podcast is not updated or saved
* unable to interact with UI after some time (not sure if it is after switching to another app putting BP into the background, or if it happens after running for a while)
* screen not sleeping when in foreground -- not sure if that's a feature or a bug at this point though

TecMunky
12-14-2017, 07:26 AM
I am not ready to go backwards, and definitely do not want to lose my feeds and settings.

My temp solution is to use another podcast app until they get this fixed.

They could come out with a new version that works exactly like the previous version until they get it working ... Just Sayin.

If it takes too long I'll be saying bye bye.

You have till Winter Solstice.

demandtheworst
12-15-2017, 06:10 AM
I only know that the decision was made to keep the release out and to fix the bugs instead of rolling back. I wish I had a better answer for you. I am trying to advocate for the users and get fixes pushed asap. I apologize for the inconvenience!

But the bugs aren't being fixed. When an app is rendered completely unusable this needs a hotfix, it's been weeks with nothing, it's still available for download, and there's not even a warning in the description that it's extra broken with newer version of Android.

I appreciate you've made it pretty clear you disagree with the developers' decision, but being as you're the only avenue for feedback that we have, I'd expect an increasing number of very upset people.

KL2001
12-21-2017, 12:53 AM
A quick fix for anyone who wants to downgrade back to stable, but can't import their backup.

Do as suggested above and backup all the episodes that can't be redownloaded.

Then find your latest backup from 4.2.19.
Unzip the backup
Edit "BackupManifest.txt"
---
Change "[timeStamp]" to "[TimeStamp]"
Change "[totalSize]" to "[TotalSize]"

Re-compress the backup and name it ".bpbak"

It should now import.

This is what worked for me.

-Kris