PDA

View Full Version : Need Volunteers to test new beta v4.2.21



KimW
02-16-2018, 11:28 AM
Hello All,

We are looking for about 20 volunteers that are willing to test and provide feedback on the newest beta 4.2.21. At this time, we are only interested in bugs. We can take feature requests once we’ve verified we have a solid build and even then, those feature requests will be worked on in future releases.

If you are interested in being a volunteer, please let me know and I will private message you information and a link to get the 4.2.21 beta version.

Thank you!

GhostFlame
02-16-2018, 12:26 PM
send me a link

humblegenius
02-16-2018, 02:50 PM
I'd be more than happy to try out the new beta. Please send me a link.

Cheetah
02-16-2018, 07:34 PM
Happy to test and report bugs, really hoping this addresses some of the big issues in 4.2.19, which can't even play podcasts for me without hanging.

Cheetah
02-16-2018, 07:57 PM
Engaging a mere three brain cells allowed me to find the APK link for this version. Initial impressions:
Main screen rendering is fixed (dark theme, notification bar).
ANR on every playback is fixed.
Bluetooth is no better than in .19: can pause playing media, but not restart after pause.
Home screen widget doesn't always work to start playback.

Using pixel 2 xl, latest Oreo release

GhostFlame
02-17-2018, 12:22 AM
What Cheetah said. Plus for some reason every time you launch it, it vibrates

Marc
02-17-2018, 02:22 AM
I am interested

Compguy
02-17-2018, 09:41 AM
I would be very interested testing this new version. I typically spend about 3 hours or more a day with BeyondPod so my interst level in fixing these issues is pretty high.

BubiBalboa
02-17-2018, 04:00 PM
Okay, I'm in.

flechaig
02-18-2018, 08:16 AM
OK I'm in too.

mlodyulek
02-18-2018, 08:59 AM
Send me the APK link

Jak
02-19-2018, 04:44 AM
Is it too late to join?
Okay so I have used the update for a little while now.
I can now add feeds.
The colour is correct on the home screen.
I can hide empty feeds and just show 'new' ones.
It did not trash my database.
But
Smart play doesn't repopulate
Automatic update did not run overnight
The colours are not right on the add feed section, text and background are the same colour (white) in the search bar for example.
I will update further when I have more.
Xperia XZ on Oreo 8.0 with January security if that helps.

Cheetah
02-20-2018, 08:38 AM
Hello All
KimW, I'm trying to reply to your PMs about this, but it won't let me because "KimW has exceeded their stored private messages quota and cannot accept further messages until they clear some space"

phalkon30
02-20-2018, 09:06 AM
Bluetooth is no better than in .19: can pause playing media, but not restart after pause.
Home screen widget doesn't always work to start playback.



What Cheetah said. Plus for some reason every time you launch it, it vibrates

I really hope these are being acknowledged and fixed before release. Bluetooth not working should be a show stopper...and it's going to be very frustrating if I have to go to manual updates to block the incoming one for a few months.

GhostFlame
02-20-2018, 11:43 AM
@Cheetah

Probably in regards to how .19 was handled

@phalkon

my Bluetooth works when the app is running, once its been cached out everything stops responding.

----------------------------------------

One more bug, i think its keeping the screen on, I have my timer set to 30 seconds but since installing this beta my screen wont turn off.

KimW
02-20-2018, 02:51 PM
KimW, I'm trying to reply to your PMs about this, but it won't let me because "KimW has exceeded their stored private messages quota and cannot accept further messages until they clear some space"

I have cleared my messages to make room for more. Please try again.

KimW
02-20-2018, 02:54 PM
Is it too late to join?
Okay so I have used the update for a little while now.
I can now add feeds.
The colour is correct on the home screen.
I can hide empty feeds and just show 'new' ones.
It did not trash my database.
But
Smart play doesn't repopulate
Automatic update did not run overnight
The colours are not right on the add feed section, text and background are the same colour (white) in the search bar for example.
I will update further when I have more.
Xperia XZ on Oreo 8.0 with January security if that helps.

Hello Jak,

Please PM me any bugs you have found and along with the requested information that were stated in the instructions sent to you with the APK. Thank you!

KimW
02-20-2018, 02:58 PM
@Cheetah

Probably in regards to how .19 was handled

@phalkon

my Bluetooth works when the app is running, once its been cached out everything stops responding.

----------------------------------------

One more bug, i think its keeping the screen on, I have my timer set to 30 seconds but since installing this beta my screen wont turn off.

Hello,

We have not been able to reproduce your screen time out issue. Please PM with specific device information and development will probably want to see your logs so I will give you a place to send those logs. Thank you!

thelovebug
02-20-2018, 03:28 PM
If it's not too late, I would appreciate testing the latest beta.

Cheers,
Dave

nitestrike
02-21-2018, 10:18 AM
Sign me up

nitestrike
02-21-2018, 12:52 PM
Here is what I have found so far, I had upgraded from BeyondPod 4.2.18. I would have to say that it has become more stable, however it still appears that they have not fixed the underling issues of being able to migrate settings. What was changed between .18 and .19? It would seem that there was some major changes and should increased the minor (4.2 to 4.3) possibly the major version 4 to 5 even.

• Dark Theme not applying to settings pages
• Default play speed, and settings did not get migrated (reset to defaults)
○ Reconfigured and looks to be working
• Speed setting(s) for individual feeds did not get migrated
○ Reconfigured and looks to be working
• Feed view did not migrate the Compact Cards setting
○ Reconfigured and looks to be working
• Feed Management flyout
○ View (My episodes) did not migrate
§ Reconfigured and looks to be working
○ After a manual refresh of the feeds - the View (My Episodes) is not showing up in the Flyout
• SmartPlay Lists - Tip does not go away after clicking OK - Did go away when checking later


Mi Mix - MIUI 9.2.1 - Android 7.0

duckman
02-22-2018, 10:44 AM
If there's any spot left, sign me in

simonlant
02-23-2018, 02:56 AM
Android Auto (app based) doesn't seem to work in v.21 the application doesn't appear in the pop up list of audio players. Not sure if this is related to being installed via 'trusted sources' or something in the app. Most other things look to be fixed/working better.

phalkon30
02-23-2018, 08:32 AM
Android Auto (app based) doesn't seem to work in v.21 the application doesn't appear in the pop up list of audio players. Not sure if this is related to being installed via 'trusted sources' or something in the app. Most other things look to be fixed/working better.

This is (most likely) because the APK was sideloaded, and not through the play store. Not saying the developers shouldn't look into it, but the link below describes why the install method you used doesn't work and how to fix it.

https://www.xda-developers.com/psa-spotify-and-other-apps-not-working-with-android-auto-heres-a-fix/

vectorjohn
02-24-2018, 02:53 AM
I am interested in testing the newest beta. On a pixel 2. .19 caused... Problems :)

BubiBalboa
02-24-2018, 12:21 PM
My findings:

- I get a notification when I switch to BP (not every time but like 70%). It's a white dot that appears in addition to the usual notification and says "BeyondPod is running"
- The phone vibrates when I switch to BP
- Dark theme is not applied to the settings page
- The setting "Remove Played from Playlist" is not respected. I have it unchecked but it removes played episodes from my SmartPlaylist even when the Playlist isn't rebuilt.

That's everything weird that I noticed. Anything else would be feature requests. ;)

mahan
02-24-2018, 07:55 PM
I'd like the link, please

OzarkCDN
02-24-2018, 08:04 PM
I'm game! On oreo 8.1 pixel xl

phalkon30
02-25-2018, 12:07 AM
My findings:

- I get a notification when I switch to BP (not every time but like 70%). It's a white dot that appears in addition to the usual notification and says "BeyondPod is running"
- The phone vibrates when I switch to BP
- Dark theme is not applied to the settings page
- The setting "Remove Played from Playlist" is not respected. I have it unchecked but it removes played episodes from my SmartPlaylist even when the Playlist isn't rebuilt.

That's everything weird that I noticed. Anything else would be feature requests. ;)

I bit the bullet because an rss feed is read was broken in .18

I agree with the above comments, on Android 8.1 it's incredibly annoying to have that white Android pop up ding when I interact with the app. It just says that beyondpod is running... Duh, it's in the foreground.

I'll add that themes are still broken in rss reading mode. The header is white text on white background, so you can't see the buttons. Dark mode is not applied to reading mode, or to the settings page.

All other features I use seem to be OK, although my setting where mostly reset to default (annoying). I'll try Bluetooth in the morning

flechaig
02-25-2018, 03:51 AM
This is my report on SONY Xperia Z5 Android 7.1.1 stock ROM.
Bluetooth controls (AVRCP profile) works fine until playback is paused for what is considered "a long time" by Beyond pod, that is to say when the notification disappears. After that, it's imposssible to resume playback. Same thing in my car : playback doesn't start automatically when BLuetooth is connected. That's the major bug of this version and is very annoying.
Thanks for your hard work to correct this.

Moebaghai
02-25-2018, 06:33 PM
I'd like the new version. Thanks!

phalkon30
02-26-2018, 10:34 AM
I figured out the annoying sound when using the .21 beta on Android 8.1, it's due to one of the notification channels.

You can reproduce by using pull to refresh on a feed. You should get a pop-up and the default system sound. Hold down on the notification, and go to settings. Disable the scheduler notification channel.

Why the developers chose to attach a sound to the scheduler I don't know...at the very least it would be nice if there were a setting in the app to disable instead of having to block it through Android System settings.

simonlant
02-26-2018, 05:41 PM
This is (most likely) because the APK was sideloaded, and not through the play store. Not saying the developers shouldn't look into it, but the link below describes why the install method you used doesn't work and how to fix it.

https://www.xda-developers.com/psa-spotify-and-other-apps-not-working-with-android-auto-heres-a-fix/


Thanks so much, these steps worked a treat and back up and running. Only a few more bugs to iron out and we have a stable build!

drmabuse
02-27-2018, 03:00 AM
Episode sync does not work in 4.2.21.

stuartajc
02-27-2018, 05:09 PM
I'd like to try out the new beta. Please send me a link.

phalkon30
02-28-2018, 07:30 AM
Is anyone else on Android 8.1 having issues with podcasts not auto-starting when connecting to Bluetooth?

Previously when I got in my car it would start my podcast at the last played location, now I have to take my phone out and open the app and then click play. It's a minor thing, but it's also why I got Bluetooth in my car...so I don't have to touch my phone.

Cheetah
02-28-2018, 07:48 AM
Is anyone else on Android 8.1 having issues with podcasts not auto-starting when connecting to Bluetooth?

Previously when I got in my car it would start my podcast at the last played location, now I have to take my phone out and open the app and then click play. It's a minor thing, but it's also why I got Bluetooth in my car...so I don't have to touch my phone.
I have a similar problem with the play button on my BT headset, but it affects Google Play Music too, not just BP (unless BP is causing the problem with GPM somehow). It isn't just starting playback -- if BP is playing and I use BT to pause it, I can't restart it without turning on the screen and clicking buttons, and this too also affects GPM.

But perversely it doesn't seem to affect the BT in my car, but that could be related to connecting the car triggering Android Auto to start.

Dennis Rockwell
02-28-2018, 09:20 AM
The car has to be set to auto-play. Whenever my battery gets disconnected, I lose that setting and have to go find it again.

GhostFlame
03-01-2018, 11:59 AM
new beta out, still widget support broken

phalkon30
03-01-2018, 05:14 PM
I have a similar problem with the play button on my BT headset, but it affects Google Play Music too, not just BP (unless BP is causing the problem with GPM somehow). It isn't just starting playback -- if BP is playing and I use BT to pause it, I can't restart it without turning on the screen and clicking buttons, and this too also affects GPM.

But perversely it doesn't seem to affect the BT in my car, but that could be related to connecting the car triggering Android Auto to start.
Hmm, I tried on my bluetooth radio and my car, both of them responded to the play pause button. Sounds like something specific to your phone if both apps do it? Maybe the bluetooth version that your headset supports?

The car has to be set to auto-play. Whenever my battery gets disconnected, I lose that setting and have to go find it again.
My car (Honda HRV) has no setting for auto play, but I will say that if Google Play Music was the last player used on my phone it will auto start every time. BeyondPod used to, but with .21 it does not anymore.

Updated to the .22 release, thoughts:
-Dark mode in RSS viewing mode is fixed! (yay)
-"all feeds" menu option seems to work again
-bluetooth controls work, at least on my radio at work. Will report back if car controls don't work
-annoying sound on refresh is gone, but the pop-up that "beyondpod is running" still exists. That's minor, and can easily be disabled by disabling that notification channel

Overall it's shaping up well. If the auto-start playing on Bluetooth can be fixed I'd say it's back to the reliability of .18 from my use cases.

pjschaffer
03-09-2018, 11:24 AM
I'd like to try the new Beta, Please send a link. Thanks

lbarreira
03-09-2018, 01:49 PM
I'd like to try the beta. please send me a link

IWasteI
03-12-2018, 09:02 AM
KimW can you send me a link to get the 4.2.21 beta . Thank you!

jlass
03-12-2018, 10:30 AM
KimW can you send me a link to get the 4.2.21 beta . Thank you!

itowill
03-12-2018, 07:03 PM
Hello Kim if there is still an apk still available I'd love to try it

Piobaire24
03-12-2018, 07:33 PM
I'm happy to test, if still needed.

KimW
03-13-2018, 09:34 AM
Hello All,

We are planning to release the latest build to the public by the end of this week so we do not need any additional volunteer users to test. We appreciate your interest and thank you to the users who did test with us and were very helpful to us through this process!

Dr G
03-17-2018, 11:16 AM
Hi KimW, I have been with Beyondpod for years, but I am losing faith. You mentioned a new version this week - any update? Dr G

shesaysidontlisten
03-17-2018, 01:18 PM
I'm in the same boat as Dr G. Pro user for years through several phones. Now I can't add new feeds and the dark theme doesn't work. Manage feeds button does nothing. Auto playlists are created every time I try to play an episode from All Feeds, even though I have it turned off. Sucks to try to play an episode and ending up with a 65 podcast playlist.

Any light at the end of this tunnel?

Toddpop1
03-17-2018, 03:48 PM
Make that a third... it's getting very discouraging. I seriously considered jumping ship earlier this week, and then I saw the "announcement" of the new version. PLEASE! Throw us a bone!

kodiak82ng
03-17-2018, 08:09 PM
some comments and issues noticed in the latest 4.2.22 beta version - hopefully can be addressed in reportedly announced version soon to be released:

Note: All below are on a Pixel 2 XL with Android 8.1 and March security update.

- In the main app Player, the skip-to-next episode button is unresponsive. It works in the mini-player in the notifications and the widget but not in the player in the main application.
- Update SmartPlay doesn't work anywhere I normally initiate it; neither from the widget popup menu 'Update Default SmartPlay' option nor in the SmartPlay menu 'Update Feeds' option. Nothing happens.
- Widget no longer has a transparent background option. I can't remember if it was an option before but it is solid black now and previously had a slightly transparent background.
- When casting to a speaker, playback will stop shortly after hitting the play button; this is true from the widget, notification, or the player inside the app. Pressing play a second time usually keeps the stream going.
- When casting to a speaker, playback will always stop when I open the Sonos app, both directly and when I use the Sonos notification to adjust volume.
- Once again, related to previous issue above, playback will stop again seconds after starting and a second press of the play button will usually keep the stream going.
- Playback does not appear to be affected by opening the Google Home app and adjusting the Cast device in use.
- It is also not affected when adjusting the volume for either the BeyondPod channel or the Sonos channel in the volume adjustment controls (initiated via the physical volume button).
- In the widget, the casting status message is in all caps. Can you switch to mixed case as the rest of the text display does as it is more pleasing to look at?
- In the widget, can you add a toggle button plus indicator of the playback speed if the option is enabled similar to the one used in the display in Android Auto?
- BeyondPod no longer appears as a media player option in Android Auto. This may be due to the fact this beta was side loaded and not from the Google Play Store.

I hope this all helps for the pending release.

KimW
03-19-2018, 09:45 AM
Hello All,

We have had some wonderful volunteer users testing the latest builds. There were some bugs that needed to be addressed that set our intended public release date back. This current build being tested is looking great and development plans to release to the public by Wednesday. If anything changes I will let you all know. Thank you!

msw141
03-19-2018, 09:55 AM
can anyone confirm if this beta worked with 8.1? The version that claimed it fixed compatibility for 8.0 was still broken on 8.1, have been unable to use the app at all, regardless of working from a backup or scratch.

phalkon30
03-19-2018, 09:56 AM
Having the error displayed below on .22 now. I have 3 smartplay playlists, the "favorite" feed is able to play but the other two are not. When I tap on them I get this error and it jumps to my favorite playlist.

No changes to my system, I guess the only thing I changed over the weekend was to remove facebook from the device. I've restarted several times.

If you'd like a log Kim, let me know and I'll email you one.

756

KimW
03-19-2018, 10:05 AM
Having the error displayed below on .22 now. I have 3 smartplay playlists, the "favorite" feed is able to play but the other two are not. When I tap on them I get this error and it jumps to my favorite playlist.

No changes to my system, I guess the only thing I changed over the weekend was to remove facebook from the device. I've restarted several times.

If you'd like a log Kim, let me know and I'll email you one.

756

Hello,

There have been additional fixes made since v 4.2.22. The latest build is looking great and expected to be released by Wednesday. Thank you.

phalkon30
03-19-2018, 12:00 PM
Edit #3: Ignore everything I said today, my default player in settings had gotten toggled to external application. Put it back to internal player, and NO issues!

It even starts playing when my car starts again! I have zero issues with the .24 release, it's back to what .18 used to be and works with all my feeds again. Thanks for taking all our crap Kim, now let's get this thing out there :)

wholly
03-19-2018, 02:56 PM
can anyone confirm if this beta worked with 8.1? The version that claimed it fixed compatibility for 8.0 was still broken on 8.1, have been unable to use the app at all, regardless of working from a backup or scratch.

Has anyone else had any luck on 8.1? Love my new phone but miss beyondpod something awful. Already on the beta stream with google. Already on .19 (Phone Pixel 2 XL)

phalkon30
03-19-2018, 03:46 PM
Has anyone else had any luck on 8.1? Love my new phone but miss beyondpod something awful. Already on the beta stream with google. Already on .19 (Phone Pixel 2 XL)

Yes, the latest private beta (.24, not on play store beta page) is working great on my Nexus 6P running stock 8.1

The .19 beta is an absolute mess and should have been pulled months ago, but try to hold out for a few more days.

BubiBalboa
03-21-2018, 05:56 AM
Version .25 for which I got a notification in-app, does not install. I'm on .22. I tried redownloading but this version fails as well.

msw141
03-21-2018, 06:46 AM
Version .25 for which I got a notification in-app, does not install. I'm on .22. I tried redownloading but this version fails as well.

i downloaded .25 off the website and it installed for me. seems to have fixed all the issues so far.

BubiBalboa
03-21-2018, 07:29 AM
I just tried again and it didn't work. Might be a problem on my end but I'm not sure why. I tried downloading on mobile and from my desktop. Tried installing directly from Firefox (mobile) and two different file managers. I tried restarting my phone just to be sure but still no success.

And I just installed a random APK from APKMirror and it installed just fine. No idea what's going on here.

E: I just installed .24 without any problems. So the problem is definitely with the .25 APK.

KimW
03-21-2018, 11:15 AM
Hello All,

The newest beta release is available now through our BeyondPod Beta Channel (v4.2.25). You can download it here: http://www.beyondpod.mobi/Android/BETA/

We will be releasing it to the Google Play store soon but for now, it is available on our Beta Channel. Thank you.

duckman
03-21-2018, 01:20 PM
Hello All,

The newest beta release is available now through our BeyondPod Beta Channel (v4.2.25). You can download it here: http://www.beyondpod.mobi/Android/BETA/

We will be releasing it to the Google Play store soon but for now, it is available on our Beta Channel. Thank you.

The app isn't compatible with your phone

Moto G4 Plus running Android 7.0
I'm currently running 4.2.22 btw...

HCpE
03-21-2018, 04:59 PM
Hi,
I installed 4.2.25 on my LG G6 last night. Videos display as blank and wouldn't play. Would lock the program until it timed out.

kodiak82ng
03-21-2018, 05:57 PM
installed v4.2.25 and some of the issues i reported are still present:


Update SmartPlay doesn't work anywhere I can find to initiate it - neither from the widget popup menu 'Update Default SmartPlay' option nor in the SmartPlay menu 'Update Feeds' option.
When casting to a speaker, playback will stop shortly after hitting the play button (from the widget, notification, or the player inside the app). Pressing play a second time usually keeps the stream going. The notifications icons in the notification bar shift around when the pause happens so something may be happening in the background when this occurs.
When casting to a speaker, playback will always stop when I open the Sonos app, both directly and when I use the Sonos notification to adjust volume.

Playback does not appear to be affected by opening the Google Home app and adjusting the Cast device in use.
It is also not affected when adjusting the volume for either the BeyondPod channel or the Sonos channel in the volume adjustment controls (initiated via the physical volume button).

In the widget, the casting status message is in all caps. Can you switch to mixed case as the rest of the text display does as it is more pleasing to look at?
In the widget, can you add a toggle button plus indicator of the playback speed if the option is enabled similar to the one used in the display in Android Auto?
BeyondPod no longer appears as a media player option in Android Auto. This may be due to the fact this beta was side loaded and not from the Google Play Store.


otherwise, definitely an improvement.

SHKaminski
03-21-2018, 10:54 PM
Android Auto Support?
BP used to work as a media player in Android Auto, but in .18 (and perhaps earlier), it stopped working.
I just installed .25 (thank you, BTW!), and it also does not appear to work with Android Auto.

Am I missing something?

Marc
03-22-2018, 02:26 AM
Can confirm these issues still exist in 4.2.25. I believe they are both specific to Android Oreo:

#1 - UPDATE_CATEGORY command causes BeyondPod to crash. Here is the stack trace:

3/21/18 11:18:27 PM: BeyondPodApplication (4.2.25) - !!! Unhandled exception !!! reason: [ android.app.RemoteServiceException ] Context.startForegroundService() did not then call Service.startForeground()android.app.RemoteService Exception: Context.startForegroundService() did not then call Service.startForeground()
at android.app.ActivityThread$H.handleMessage(Activit yThread.java:1768)
at android.os.Handler.dispatchMessage(Handler.java:10 6)
at android.os.Looper.loop(Looper.java:164)
at android.app.ActivityThread.main(ActivityThread.jav a:6494)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsC aller.run(RuntimeInit.java:438)
at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:807)

#2 - Home screen widget does not work when the app is not actively running. Pressing the play button on the widget does nothing.

itowill
03-22-2018, 06:57 AM
Hey Kim
I've waited with everyone else to get the new beta but when I install it says incompatible. My phone is on 7.1 will this beta work on non Oreo devices o have Motorola vanilla nougat updates last night. Please advise as current .19 beta is non function
Thank in advance I am in Google play beta user is this.24 or .26 available. Can you send me apk link?

Will.

Cheetah
03-22-2018, 08:44 AM
Android Auto Support?
BP used to work as a media player in Android Auto, but in .18 (and perhaps earlier), it stopped working.
I just installed .25 (thank you, BTW!), and it also does not appear to work with Android Auto.

Am I missing something?

AA will only use media apps installed via the play store. If you sideload the BP beta, AA won't use it. There's a way to "trick" things so it looks like it came from the play store, however:
https://www.xda-developers.com/psa-spotify-and-other-apps-not-working-with-android-auto-heres-a-fix/

KimW
03-22-2018, 09:27 AM
The app isn't compatible with your phone

Moto G4 Plus running Android 7.0
I'm currently running 4.2.22 btw...

Hello,

We have only a few reports of users unable to install. It seems to be certain devices. Development is aware and is trying to figure out why certain devices are having issues. I will get back with you when I have an update. Thank you!

KimW
03-22-2018, 09:27 AM
Hey Kim
I've waited with everyone else to get the new beta but when I install it says incompatible. My phone is on 7.1 will this beta work on non Oreo devices o have Motorola vanilla nougat updates last night. Please advise as current .19 beta is non function
Thank in advance I am in Google play beta user is this.24 or .26 available. Can you send me apk link?

Will.

Hello Will,

Yes, this beta works on other Android versions other than Oreo. We have only a few reports of users unable to install. It seems to be certain devices. Development is aware and is trying to figure out why certain devices are having issues. I will get back with you when I have an update. Thank you!

KimW
03-22-2018, 09:56 AM
Hi,
I installed 4.2.25 on my LG G6 last night. Videos display as blank and wouldn't play. Would lock the program until it timed out.

Hello,

I have sent you a private message to collect some more information. Thank you!

SHKaminski
03-22-2018, 02:12 PM
AA will only use media apps installed via the play store. If you sideload the BP beta, AA won't use it. There's a way to "trick" things so it looks like it came from the play store, however:
https://www.xda-developers.com/psa-spotify-and-other-apps-not-working-with-android-auto-heres-a-fix/

Thank you! This trick worked with .25. I'll keep the link for future reference.

simonlant
03-22-2018, 06:05 PM
Can confirm these issues still exist in 4.2.25. I believe they are both specific to Android Oreo:

#1 - UPDATE_CATEGORY command causes BeyondPod to crash.

#2 - Home screen widget does not work when the app is not actively running. Pressing the play button on the widget does nothing.

Strange updated to. 25 and as a coincidence got Oreo updated on on my S8 this evening. #1 seems to work ok for me (long hold on category name, press 'update [category name]' - just does feeds in that category, doesn't crash.)
#2 i confirm if the app is closed the widget doesn't respond, app open and it works fine. So this is an issue for me.

Marc
03-23-2018, 02:23 AM
Strange updated to. 25 and as a coincidence got Oreo updated on on my S8 this evening. #1 seems to work ok for me (long hold on category name, press 'update [category name]' - just does feeds in that category, doesn't crash.)
#2 i confirm if the app is closed the widget doesn't respond, app open and it works fine. So this is an issue for me.

For #1 I'm referring to the UPDATE_CATEGORY API command http://www.beyondpod.mobi/android/help/FAQAPIs.htm

simonlant
03-23-2018, 12:49 PM
For #1 I'm referring to the UPDATE_CATEGORY API command http://www.beyondpod.mobi/android/help/FAQAPIs.htm
Thanks for clarity Marc, I didn't know that functionality was there!