PDA

View Full Version : Beta Version 4.2.28 is now available!



KimW
03-29-2018, 09:10 AM
The current beta has been moved forward to the Google Play beta channel.


Fixed bug causing installation errors for certain ABIs.
Added workaround for certain external commands which brings the application to the foreground to prevent crashing.
Added workaround for bug in Android Oreo SDK causing underlying service crashes.
Fixed crash when viewing video podcasts.
Fixed compatibility issue with certain ABIs.

asmalldharma
03-29-2018, 10:15 AM
For me, the episode duration (5 min left, etc.) aren't loading under the episode titles for some episodes in the playlist. The full playlist run-time is accurate, though. Also sometimes getting a weird arrow-wheel notification that won't clear, after category update. I THINK it's updating just fine, but the blank notification just sits there afterward.

KimW
03-29-2018, 10:48 AM
For me, the episode duration (5 min left, etc.) aren't loading under the episode titles for some episodes in the playlist. The full playlist run-time is accurate, though. Also sometimes getting a weird arrow-wheel notification that won't clear, after category update. I THINK it's updating just fine, but the blank notification just sits there afterward.

Hello,

The "time left" isn't showing after you have started "play" on the episodes? Or have you not started play on these episodes yet?

Does the "Arrow-wheel" notification say anything with it?

asmalldharma
03-29-2018, 11:01 AM
It shows up after I start playing the episode. In the past, it has always just been there. It's not for all episodes. Seems to be a random selection. I'll pay more attention the next time the notification bug happens, or just take a screenshot. I wonder if the two bugs are connected somehow? Like something is happening on my phone to interrupt the final steps of an update.

KimW
03-29-2018, 11:15 AM
It shows up after I start playing the episode. In the past, it has always just been there. It's not for all episodes. Seems to be a random selection. I'll pay more attention the next time the notification bug happens, or just take a screenshot. I wonder if the two bugs are connected somehow? Like something is happening on my phone to interrupt the final steps of an update.

The episodes that are not showing the time, are those actually downloaded episodes? Or did you add them to your playlist without actually downloading them (just streaming)? If an episode is just added to the playlist without it being downloaded, it will not show the time until it is played and then it will show the time left. Downloaded episodes show the time right away after it has been fully downloaded.

Yes, please take a screenshot of the notification you are seeing the next time you notice it. Thank you!

asmalldharma
03-29-2018, 11:43 AM
They are downloaded episodes.

dlynch
03-29-2018, 11:56 AM
Two quick things:

1. In All Feeds view, touching an episode crashes the app rather than bringing up the episode details. AFAIK all the other views are fine. (This is an old bug, still present in .28)

2. Chromecast icon is black on gray, and looks the same whether casting or not.

dlynch
03-29-2018, 12:14 PM
1. Changing the filter can stop the crash. Always crashes in the All Feeds view with All Episodes filter.

2. The gray on gray Cast icon is in the Player screen. The color is different in dark theme, but the icon still doesn't change when casting.

HCpE
03-29-2018, 08:59 PM
Posted this to 4.2.25 thread. Oops.

A couple issues noted. First, appears to be pretty stable for me. Running on an HP Touchpad running custom 8.1 and on stock LG G6.
Episode Sync doesn't seem to be working. Anyone else notice anything?
Higher speeds (2x) sound a little ratty. Seems to depend on if screen is on.

Timsroot
03-30-2018, 08:17 AM
When I try to fast forward from the notifications tray, the notification goes away.

Kingcrimson
03-30-2018, 08:21 AM
Notification persists as long as something is in the playlist. Can't swipe it away. Only way I can get rid of it is Force Close.

KimW
03-30-2018, 10:20 AM
Notification persists as long as something is in the playlist. Can't swipe it away. Only way I can get rid of it is Force Close.

Hello,

What notification is stuck for you? Can you please provide more detail of the issue you are having. Thank you.

Kingcrimson
03-30-2018, 10:38 AM
764

Not sure what to call it.

KimW
03-30-2018, 11:58 AM
When I try to fast forward from the notifications tray, the notification goes away.

Hello,

The tray disappears when you fast forward a few seconds? Or to the end of the episode? Can you give some more details please?

Mark oulaghan
03-31-2018, 07:26 AM
After this update I cannot play any podcast

Kingcrimson
03-31-2018, 09:12 AM
It goes away if I hut play, then pause, then back out and swipe away the now playing notification.

Comes back as soon as I start BP again.

MiniMax
03-31-2018, 01:00 PM
4.2.28 is incredibly slow for me. Running on Pure Nexus 7.1.1 on a Nexus 6. Everything is slow. Everything. The app eventually responds but it is like it is running in molasses. Tried restarting the phone.

BubiBalboa
04-01-2018, 06:41 PM
Can confirm. It's pretty slow in some situations. And the whole notification stuff needs work. It's behaving very weird.

Marc
04-01-2018, 10:47 PM
4.2.28 still has the bug where the home screen widget does not work on Android Oreo if BeyondPod is currently running. I run into the bug less often in 4.2.28, I believe because it is harder for BeyondPod to be removed from memory due to all the foreground notifications which BP adds (which is an entirely different problem). However, if I have no current BP notifications, and it's been a while since I've used BP (meaning it has likely been removed from memory), the buttons on the home screen do not function.

Disabling Doze for BP seems to fix the issue, so it seems like it may be a bug associated with making the widget work properly with Doze.

Timsroot
04-02-2018, 11:41 AM
Yes, if I fast forward a few seconds, the notification disappears from the system tray.

Also, I've noticed that the widget doesn't seem to do anything most of the time.

KimW
04-02-2018, 01:00 PM
After this update I cannot play any podcast

Hello,

What device and version of Android are you using? Are there any messages popping up when you try and play episodes? Are you able to download episodes but just not play them? Can you please give more details?

dlynch
04-02-2018, 02:52 PM
The BP notification title gets separated from the notification body (the player controls). I've been noticing this and finally figured out quite what is going on.

Here's a simple case (on Oreo): start something playing. With BP still in front, pull down the notifications. Touch the Pause button in the BP notification. The player controls disappear from the notification, but the title is still there. In fact, a new notification has been created that has no title but does have the player controls. If you switch to another app, eventually the notification with just the title goes away, and the player controls move to the top, still title-less. Switch back to BP and the title-only notification reappears.

Here are some examples:

765
766
767

ric666
04-03-2018, 02:42 AM
I have a bug with episode names.

Once downloaded the episode name becomes the podcast name plus a series of numbers and not the episode name. This is present in my episodes and in the playlist. However if I change my view to all published the correct name is displayed.

phalkon30
04-05-2018, 08:40 AM
The BP notification title gets separated from the notification body (the player controls). I've been noticing this and finally figured out quite what is going on.

Here's a simple case (on Oreo): start something playing. With BP still in front, pull down the notifications. Touch the Pause button in the BP notification. The player controls disappear from the notification, but the title is still there. In fact, a new notification has been created that has no title but does have the player controls. If you switch to another app, eventually the notification with just the title goes away, and the player controls move to the top, still title-less. Switch back to BP and the title-only notification reappears.

Here are some examples:

765
766
767

I'm finding a similar issue since updating to .28 yesterday (Oreo 8.1 March patch). It's honestly hard to describe, but there are typically two BP icons in my notification tray, one with the controls and one without. This is a different behavior since .25

Sometimes after pausing and putting BP in the background I lose player controls, sometimes they stay. Sometimes I get a persistent notification that only goes away on reboot.

KimW
04-05-2018, 09:22 AM
I'm finding a similar issue since updating to .28 yesterday (Oreo 8.1 March patch). It's honestly hard to describe, but there are typically two BP icons in my notification tray, one with the controls and one without. This is a different behavior since .25

Sometimes after pausing and putting BP in the background I lose player controls, sometimes they stay. Sometimes I get a persistent notification that only goes away on reboot.

The developers are aware of this issue already and are creating a fix.

BubiBalboa
04-06-2018, 09:35 PM
The newest update seems to have fixed the weird notification behavior. Great!

dlynch
04-07-2018, 11:12 AM
With the .30 update the notification behaves sensibly, but it's still not right: now the notification never includes the name of the application, like all other notifications do.

One other thing that's been adjusted is worse than before all these updates: before, with the normal theme, the Cast icon was always white, like all the other things that appear in the top bar. Now it's sometimes white, sometimes black (in the episode list screen) and sometimes green (when casting is active). In all other apps (and in the episode screen) the Cast control is filled in when casting is active, without changing color. It would be better to stick with that convention.

Finally there's the crash I reported when I try to access an episode's details from the All Episodes list. It's still there. My guess is that the problem is just the number of episodes in that list (over 2200 currently). If I filter the list down, the crash doesn't happen. BTW - what I mean by "crash": when I touch an episode in the list, BeyondPod instantly disappears. When I bring it up again, the app goes through the Loading episodes... step.

uManiac
04-08-2018, 11:26 AM
The "crash" described above is also present in 4.2.18 so it's not new. I've got about 3.500 episodes in my all feeds list and BP crashes after hanging for a while. I'm on Oreo 8.0.

MiniMax
04-08-2018, 08:47 PM
I ended up removing 4.2.28, and went back to 4.1.18, the latest public release. That worked flawlessly. I then tried a few early 4.2 betas which also worked. Until I hit 4.2.28 which again was sloooooooow. Time progress skipped 5 seconds between updates. Rotating the phone (redrawing the screen) was slooooooow. Uninstalled .28 and tried .29 (worked), and is now running 4.2.30 without problems.

KimW
04-09-2018, 09:25 AM
With the .30 update the notification behaves sensibly, but it's still not right: now the notification never includes the name of the application, like all other notifications do.

One other thing that's been adjusted is worse than before all these updates: before, with the normal theme, the Cast icon was always white, like all the other things that appear in the top bar. Now it's sometimes white, sometimes black (in the episode list screen) and sometimes green (when casting is active). In all other apps (and in the episode screen) the Cast control is filled in when casting is active, without changing color. It would be better to stick with that convention.

Finally there's the crash I reported when I try to access an episode's details from the All Episodes list. It's still there. My guess is that the problem is just the number of episodes in that list (over 2200 currently). If I filter the list down, the crash doesn't happen. BTW - what I mean by "crash": when I touch an episode in the list, BeyondPod instantly disappears. When I bring it up again, the app goes through the Loading episodes... step.

For the Chromecast coloring, that is controlled by Google so our developers overwrote some code to make the colors change when casting to Green due to you stating it did not change color at all before. Our developers can't control the coloring too much as that is set by Google and out of their hands but they did try and help distinguish a bit more by overwriting the colors the best they could with Google's current codes.

Thank you for the extra details about your episode details issue. I will pass this new information along.

dlynch
04-09-2018, 11:04 PM
It seems I wasn't clear about the fundamental problem with the color of the Chromecast icon. I think that previously, it was always white. Sometimes just an outline and sometimes filled in, but always white. White is good because the background is never white. With the recent changes, the light theme had it colored black. This is bad because some of the title bars are dark gray. Black on dark gray is not visible! Also, all the other icons in the title bar are always white.

Always white seems to be the right answer.

Marc
04-10-2018, 02:23 AM
Oh the episodes list, I'm seeing random looking characters next to the podcast date, such as "(,D)", "(R,D)", and "()". I don't have an old version of BP installed anywhere, so it might be that these characters have always been there and I've just never noticed. Below is a screenshot showing this issue:

https://imgur.com/nopAfhW

Are these characters meant to be appearing? It looks like it may be meant as debug text.

AndyCr15
04-10-2018, 04:05 AM
I've just updated to 4.2.30 and the menu button has gone from my widget? It was the easiest way to update my smartplay list. I guess I'll roll back and turn off updates again... :(

**EDIT** Oh, it's just come back? Nevermind then :)

phalkon30
04-10-2018, 08:50 AM
Oh the episodes list, I'm seeing random looking characters next to the podcast date, such as "(,D)", "(R,D)", and "()". I don't have an old version of BP installed anywhere, so it might be that these characters have always been there and I've just never noticed. Below is a screenshot showing this issue:

https://imgur.com/nopAfhW

Are these characters meant to be appearing? It looks like it may be meant as debug text.

I'm on the .29 release and do not see these characters, nor do I remember seeing them.

KimW
04-10-2018, 11:01 AM
Oh the episodes list, I'm seeing random looking characters next to the podcast date, such as "(,D)", "(R,D)", and "()". I don't have an old version of BP installed anywhere, so it might be that these characters have always been there and I've just never noticed. Below is a screenshot showing this issue:

https://imgur.com/nopAfhW

Are these characters meant to be appearing? It looks like it may be meant as debug text.

I am not seeing these characters on any of my devices. Very strange. I will keep an eye out to see if I get any more reports from anyone else seeing these characters.

dlynch
04-10-2018, 05:42 PM
(R, D) shows up next to the date for every episode when you look at the ALL PUBLISHED list for a feed. This isn't new, but I have no idea what the R or D mean.

jhonen
04-10-2018, 06:07 PM
I'm seeing ()

dlynch
04-11-2018, 12:24 AM
See the original post that describes the variations that appear.

AndyCr15
04-11-2018, 06:08 AM
Actually, my Android watch seems to permanently show the BeyondPod controls, even when not in use and not in my phone notification drop down. (4.2.30)

phalkon30
04-11-2018, 09:55 AM
(R, D) shows up next to the date for every episode when you look at the ALL PUBLISHED list for a feed. This isn't new, but I have no idea what the R or D mean.

Yeah, I still don't see these on any of the 5 podcasts I subscribe to when viewing in all published mode for a feed. Are these downloaded episodes?

.29 release, Android Oreo 8.1, Nexus 6P with NPR, SYSK, and TWIT podcasts.

KimW
04-11-2018, 03:34 PM
Actually, my Android watch seems to permanently show the BeyondPod controls, even when not in use and not in my phone notification drop down. (4.2.30)

Android Wear support has been dropped with BeyondPod.

Marc
04-12-2018, 02:27 AM
Hah... turns out the strange characters like "(,D)" show up if you have checked the "Enable Logging" setting in Advanced Settings. After unchecking that checkbox, the characters are gone.

Toddpop1
04-12-2018, 06:03 AM
I have a bug with episode names.

Once downloaded the episode name becomes the podcast name plus a series of numbers and not the episode name. This is present in my episodes and in the playlist. However if I change my view to all published the correct name is displayed.

I am getting the same thing.... i redownloaded those episodes and it went away, only to come back when the next episode automatically downloads. I reloaded the feed and it still happens.

KimW
04-12-2018, 09:59 AM
Hah... turns out the strange characters like "(,D)" show up if you have checked the "Enable Logging" setting in Advanced Settings. After unchecking that checkbox, the characters are gone.

@jhonen @dlynch

Yes, Marc is correct in this. I was unaware of the characters as well but development confirmed that this is expected behavior when "Enable Logging" is checked.

phalkon30
04-12-2018, 10:38 AM
I am getting the same thing.... i redownloaded those episodes and it went away, only to come back when the next episode automatically downloads. I reloaded the feed and it still happens.

Out of curiosity, if you long press on a feed and edit settings, then go to advanced settings, do you have "force unique names" checked? Tried unchecking that?

adamlopresto
04-12-2018, 02:28 PM
Android Wear support has been dropped with BeyondPod.

That's not the point, though. There's now (often) a permanent notification on the watch, showing play controls. It's not there all the time, but it's often there even if there's nothing playing and no notifications on the phone, and it can't be removed. I'm not asking for special control from Android Wear, I'm just asking for it to not be broken.

Marc
04-14-2018, 11:47 PM
Sharing with BeyondPod still does not work in the latest version. Originally reported here: http://www.beyondpod.com/forum/showthread.php?4335-4-2-19-Share-with-BeyondPod-does-not-work

Steps:
1) Open RSS feed URL in device web browser
2) Open the share menu to share the URL ("Share..." in Chrome browser)
3) In the Share menu, choose "Subscribe in BeyondPod"
-> At this point, BeyondPod opens, but it does not subscribed to or open the RSS feed. It just opens whatever the last BeyondPod menu you had open was

I believe this issue is specific to Android Oreo

Toddpop1
04-16-2018, 03:23 PM
Out of curiosity, if you long press on a feed and edit settings, then go to advanced settings, do you have "force unique names" checked? Tried unchecking that?
yes it is checked

phalkon30
04-16-2018, 04:51 PM
yes it is checked

Have you tried un-checking it? I believe when checked this adds numbers to the file name to make it unique.

Come to think of it, I think I've seen your issue when I made a backup of the episode mp3s, reinstalled BP, then copied the backup over again. This makes sense if you don't see the files in "all published" because that list is from the RSS feed. The "my episodes" list shows all downloaded files in that folder. Try navigating to that folder using some kind of file explorer app, and delete all of the files in that podcasts folder. You may have to re-download them, but I *think* it should fix your issue. (I'm not a developer, just trying to help you troubleshoot)

BubiBalboa
04-29-2018, 12:58 PM
Bug: in versions up to .31

In some situations (from playlist for example) reading the episode notes will mark the episode as played.

kodiak82ng
05-05-2018, 07:07 PM
currently using website v4.2.32

previously, after updating from v4.2.28 to v4.2.30 or .31 (can't remember exactly), i suddenly started having issues downloading episodes due to beyondpod throwing errors saving to or reading from /storage/emulated/0/BeyondPod directory. this is where all of my podcasts have been stored for a long time - probably a leftover from an upgrade.

i've been experiencing the "can't cast episode" problem since upgrading around ~v4.2.22 along with other oddities as well.

i decided to uninstall and see if a clean install would clear any of the issues. well, this hasn't been fun.

after restoring the install from a backup configuration, the episode download and playback works. my smartplay configuration works ("update smartplay" still only rebuilds the playlist and doesn't initiate a feed update and download of new episodes as it did prior to ~v4.2.18). i can cast episodes/sources that were failing previously. episode sync looks to be updating from the log screen. starts to look good.

now, go check feedly integration...

try adding a feed, import from Feedly -> blank screen (-> and black bar at top but no feeds in a list). hmm, usually i'll see a list of my feedly feeds and a box indicator for feeds that are missing locally. the screen is blank. no indicator of a login problem, nothing.

fine, its been awhile since i've made sure my feedly login is set correctly so i'll logout and login again and we'll see. get to login screen, select Google account credentials, aaaand, fail Oauth process since BeyondPod uses the web-tool login and google doesn't allow this any longer (since 8/2016?). is this something BeyondPod can fix since it's kinda proxying BP->feedly->google for auth?

ok, so feedly allows me to add a feedly login credential option to my account so lets do that. *scurries over to a computer to create and setup feedly local account and come back to beyondpop*

now, logging in with feedly account in beyondpop i get the same blank screen. checking the Environment Info log screen i see in the "FEEDLY INFO" section logged in is yes, login expires 3:20 pm may 12, 2018, has user is yes and can re-login is yes.

so, i'll say the feedly integration is broken. some other past issues are fixed by going through the reinstall but would really like to get feedly working again ASAP.

also, it would be very much appreciated if your devs would add these betas to google play beta option. installing betas from a download breaks the Android Auto integration which is another annoyance.

Timsroot
05-10-2018, 07:21 AM
When I use the player, even for audio, it won't let the display sleep unless I exit the app. I don't remember this in past versions, and don't see a seeing to change this. This makes my battery drain extremely quickly

KimW
05-10-2018, 10:47 AM
When I use the player, even for audio, it won't let the display sleep unless I exit the app. I don't remember this in past versions, and don't see a seeing to change this. This makes my battery drain extremely quickly

This was fixed in v4.2.32. Please refer to the following feed: http://www.beyondpod.com/forum/showthread.php?4512-4-2-30-Screen-won-t-go-to-sleep-while-BP-is-active

pettersundlof
05-17-2018, 06:33 AM
I'm having trouble seeing old/played/downloaded-deleted episodes in feeds. I.e., it's only showing me new, unplayed episodes. I'm missing the "see all published episodes" (paraphrased) functionality. 4.2.32 on Android P

Edit: ooops, must've missed the "my episodes / all published" dropdown in the header. Was so used to looking for the grey text below