PDA

View Full Version : EpisodeSync Mostly Not Working



milliman
03-30-2018, 09:47 AM
I am happy that we have a new version of BeyondPod (4.2.28) and I hope that the developers continue to fix bugs and enhance it very regularly.

I would like to switch back to BeyondPod as my sole podcast application but there is still one major annoyance preventing me from doing that: EpisodeSync doesn't work. I got it to work once but since then it tries but doesn't do anything. The log says "Sync failed! Service error: -1, No value for type." This message is repeated every few minutes. Both of my devices are experiencing the same issue. I turned off and on the feature. Logged out and back into my account. Neither of these two steps made a difference. I tried to force a sync by changing feed contents and play position of an episode but it doesn't seem to trigger a synchronization. There is no longer any way to force a manual synchronization. Hopefully this bug will get fixed next because synchronizing episodes and play positions is an extremely valuable function.

KimW
03-30-2018, 10:59 AM
I am happy that we have a new version of BeyondPod (4.2.28) and I hope that the developers continue to fix bugs and enhance it very regularly.

I would like to switch back to BeyondPod as my sole podcast application but there is still one major annoyance preventing me from doing that: EpisodeSync doesn't work. I got it to work once but since then it tries but doesn't do anything. The log says "Sync failed! Service error: -1, No value for type." This message is repeated every few minutes. Both of my devices are experiencing the same issue. I turned off and on the feature. Logged out and back into my account. Neither of these two steps made a difference. I tried to force a sync by changing feed contents and play position of an episode but it doesn't seem to trigger a synchronization. There is no longer any way to force a manual synchronization. Hopefully this bug will get fixed next because synchronizing episodes and play positions is an extremely valuable function.

Hello,

I am going to have you send your logs in so I can pass those to the developers to be looked at. I will private message you with where to send those to.

uManiac
04-15-2018, 03:14 PM
I'm having this same problem on 4.2.30. I seem to be able to sync one way once if I log out of episode sync and then log back in. I can send logs if you like.

uManiac
04-15-2018, 03:35 PM
I'm wondering about this, I have version 4.2.18 on another device. If I only sync 4.2.30 a few times that seems to work fine. As soon as the 4.2.18 device syncs then thee 4.2.30 stops syncing. Maybe this is the problem, incompatible versions during sync? I'm going to update my other device to 4.2.30 and see what happens.

uManiac
04-15-2018, 04:15 PM
Tried it, doesn't seem to help. Now both devices are at version 4.2.30. one syncs without errors, the other always gets the Server error -1, No value for type. If I log out of the device that gets the error and then log back in then that device can sync and the other gets the Server error -1.

HCpE
04-15-2018, 04:41 PM
I have not had episode sync work since 4.2.18. Currently using 4.2.30 on both my LG G6 and my HP Touchpad running Dirty Unicorns Oreo 8.1. I consistently get "sync failed! Service Error: -1, no value for type."

phalkon30
04-16-2018, 09:06 AM
Sync has worked fine for me on my 6P running 8.1 Oreo and my S5 running LOS 14.1 on every beta between .18 and .30, it shows as having synced yesterday in fact.

I tried to look at the logs, but in .30 it says that no log file exists (which looks like a bug to me). Maybe try logging out and logging in again?

HCpE
04-16-2018, 01:45 PM
Thanks for looking! I'm not sure what the issue is. But would be nice to know what "sync failed! Service Error: -1, no value for type." It is actively trying to sync, but eventually times out. I have logged out and back in again as well. When I had one device with .18 and another with .27, the .27 device would pull from sync from .18, but would not post it's changes.

phalkon30
04-16-2018, 02:27 PM
I'll be honest, after reading the other thread on this topic I'm questioning if my other device is actually syncing (it's at home, rarely used). My main device does not error, I'll try and remember to check if the other device does now that it's updated to .30

asdef1
04-17-2018, 07:41 AM
I'm getting the same "Sync failed! Service error: -1 No value for type" error using BeyondPod 4.2.30 on both my Google Pixel on Android 8.1.0 and my Acer B3-A20 on Android 5.1.

phalkon30
04-17-2018, 08:48 AM
I'll be honest, after reading the other thread on this topic I'm questioning if my other device is actually syncing (it's at home, rarely used). My main device does not error, I'll try and remember to check if the other device does now that it's updated to .30

I checked, both 7.1 and 8.1 devices are syncing fine on the .30 release.

What do you guys have for settings? I have the "when episodes are deleted..." checked, and "Always" selected for accept feeds from other devices.

This seems like it would be easy for the developers to troubleshoot based on the error...

KimW
04-17-2018, 10:10 AM
Hello,

Development is looking into the EpisodeSync feature already but I will report the error some of you are experiencing. They may request your logs so if they do I will PM you where to send those so I can get them to the developers directly.

KimW
04-17-2018, 10:20 AM
This bug has already been reported to development and they are looking into this. Thank you!

KimW
04-18-2018, 11:00 AM
I checked, both 7.1 and 8.1 devices are syncing fine on the .30 release.

What do you guys have for settings? I have the "when episodes are deleted..." checked, and "Always" selected for accept feeds from other devices.

This seems like it would be easy for the developers to troubleshoot based on the error...

It would be useful to know what settings you all have from syncing. Perhaps there is an issue with certain sync settings.

asdef1
04-18-2018, 06:25 PM
It would be useful to know what settings you all have from syncing. Perhaps there is an issue with certain sync settings.

I have always delete checked and always accept feeds from my other devices selected.

KimW
04-19-2018, 10:04 AM
I have always delete checked and always accept feeds from my other devices selected.

Thank you for your additional information!

dyastrab
04-19-2018, 03:31 PM
Same issue here. I thought something had gotten corrupted in my devices, but I deleted and re-downloaded the app several times and several different ways and still have the same error.

paksen
05-09-2018, 10:36 AM
Has this issue been resolved yet? EpisodeSync is not working for me.

dmasciangelo
05-09-2018, 11:07 AM
Same issue for me, since updating to 4.2.3 on all my devices Episode Sync not functioning on any. Tried logoff and back on, deleting cache, deleting data and reconfiguring feeds, any update? This is the most valuable feature on the app for me...

KimW
05-09-2018, 11:12 AM
Has this issue been resolved yet? EpisodeSync is not working for me.

The developers are still working on a fix for episode sync. Not everyone is experiencing issues with syncing so they are trying to figure out why only some users are and others are not.

dmasciangelo
05-09-2018, 11:35 AM
The developers are still working on a fix for episode sync. Not everyone is experiencing issues with syncing so they are trying to figure out why only some users are and others are not.

I am happy to help troubleshoot, let me know what logs I can send that may be useful.

Alta
05-12-2018, 04:32 PM
I use EpisodySync on two devices and both show me that the last sync date was 4 May. Is there something that has happened recently that made it stop working? I can't seem to find a way to manually trigger a sync to see what's going on.

HCpE
05-14-2018, 03:41 PM
My episode sync is still not working. Have posted the error before. Let me know and I'll send again.
Thanks!

asdef1
05-14-2018, 06:46 PM
Would a detailed log help? Setting > advanced> general > enable logging . If so please let me know and I'll turn it on, and post the results here.

KimW
05-15-2018, 09:58 AM
Would a detailed log help? Setting > advanced> general > enable logging . If so please let me know and I'll turn it on, and post the results here.

We have collected additional information from some users and the developers are looking into this. If the developers need more information, I will contact you to collect that. Thank you!

xairrick
05-24-2018, 03:50 PM
For a long time I was able to use the EposideSync to sync between two devices. About a month ago it stopped sync'ing. If I logout and log back in, last sync date is set, but it doesn't appear to have sync'd the episodes and the last sync date never updated after that (eg still show May 18)

xairrick
05-25-2018, 10:01 AM
I'm having the same issue. used to work fine, but has sync'd in over a month. let me know if you need my logs.

NOTE: my device ran out of space about a month ago. a hidden folder consumed 50GB on my SD Card. I used by PC to delete the hidden folder. Maybe running out of space triggered the problem(around the same time sync stopped working)

Alta
05-30-2018, 02:31 AM
We have collected additional information from some users and the developers are looking into this. If the developers need more information, I will contact you to collect that. Thank you!

Do you have any updates on the situation? For me, sync remains broken.

Wendigo
05-30-2018, 05:11 AM
Same here. I'm looking for another application.

KimW
05-31-2018, 10:28 AM
Do you have any updates on the situation? For me, sync remains broken.

I do not have an update quite yet from development on this. They are working on fixes for a few things including episode sync.

Wendigo
05-31-2018, 06:00 PM
ETA of the fixes?

KimW
06-04-2018, 10:33 AM
I do not have an update quite yet from development on this. They are working on fixes for a few things including episode sync.


ETA of the fixes?

Hello,

As I stated below, unfortunately I do not have an update about this from development yet.

xairrick
07-23-2018, 09:15 AM
@KimW The syncs are still broken (at least mine are), hasn't worked in over 2 months(maybe 3). any news on if it being looked at or not. or should people that need episode sync move to a different app?

KimW
07-23-2018, 10:13 AM
@KimW The syncs are still broken (at least mine are), hasn't worked in over 2 months(maybe 3). any news on if it being looked at or not. or should people that need episode sync move to a different app?

Hello,

This has been fixed and will be included in the next BETA release (v4.2.34). I do not yet have a date for when the next BETA version will be released but I am thinking within the next few weeks.

xairrick
07-24-2018, 07:41 AM
Hello,

This has been fixed and will be included in the next BETA release (v4.2.34). I do not yet have a date for when the next BETA version will be released but I am thinking within the next few weeks.

It's good to hear a fix is being worked on. Let me know if you need a beta tester.

KimW
07-25-2018, 10:26 AM
Hello All,

A fix for episode sync has been implemented in the latest BETA release, v 4.2.34.

uManiac
08-03-2018, 09:49 AM
Hello All,

A fix for episode sync has been implemented in the latest BETA release, v 4.2.34.

Works for me in 4.2.34, thanks!

KimW
08-03-2018, 03:10 PM
Works for me in 4.2.34, thanks!

Great! Thank you for reporting back :)

BoulderBill
09-12-2018, 10:20 PM
On 4.2.37 on both my old tablet and new Lenovo Tab 4, logged in on both, and select the delete and always option on both, but neither update the other.

Anyone else have it working?

HCpE
09-14-2018, 09:03 AM
Episode Sync not working on either Tablet or phone since I installed 4.2.38 last night.

Le_Poilu
09-20-2018, 08:16 AM
Hi

Same for me here
No more episode sync since .38 :(

Le_Poilu
10-08-2018, 08:16 AM
Anything about this issue ?

No syncing since 15 september here, on both of my devices. This is since .38 release.

KimW
10-08-2018, 11:16 AM
I will have development look into this again.

Le_Poilu
10-26-2018, 02:35 AM
Any news about this ?

Episode sync is still down since 15 sept on my devices...

phalkon30
10-26-2018, 10:49 AM
I only have one device on BP now, but episode sync is working for me on .41 with no errors in the sync log.

Pixel XL2 running Android Pie, although I have battery optimization off for BP, maybe that's why it's working for me?

Also, I had sync errors when google transferred the app to my new Pixel. I had to log out then log in again and it's worked since. Maybe try that?

Le_Poilu
10-28-2018, 10:53 AM
If I log out, log in it seems to make a sync, but there's no syncing between devices.
I have 2 devices and nothing is synced between them, even after log out - log in in both devices.

narf
11-06-2018, 02:39 PM
Works on my Android 6 device but not on 7.1 or 8.

So one of my phones keeps sending stuff to the server but none of my other devices care: Service Error 1, no value for type

drmabuse
11-29-2018, 09:44 AM
Since today there is a new failure on episode sync:

Sync failed! Service error: 500, The database 'beyondpodsyncwest' has reached its size quota. Partition or delete data, drop indexes, or consult the documentation for possible resolutions.

colonelheero
11-30-2018, 05:24 PM
Just want to add another data point that I'm facing the same error since yesterday. please help!

uManiac
12-05-2018, 03:09 PM
I have this quota error also.

curmudgeon
12-07-2018, 07:42 AM
when this happened before it was on their server not our devices. I hope they notice soon.

AndyCr15
12-08-2018, 08:50 AM
Is this not working at all? I get -

Unable to connect to BeyondPod servers. Please try again later.

phalkon30
12-10-2018, 08:20 AM
I don't really use sync between devices anymore, but I'm getting this error as well now. Maybe that's why this app is always in the foreground lately?

Sent logs to Kim and developers

curmudgeon
12-28-2018, 06:52 PM
It's been broken for over a month now, thinking about changing apps.

Le_Poilu
01-03-2019, 05:10 AM
I gave up on BP :(

EpisodeSync not working anymore (since september for me) and absolutely no return from devs had reason of my patience... Using Pocket Cast now, until BP devs get their fingers out of their ass...

KimW
01-16-2020, 05:02 PM
Hello All,

EpisodeSync server error has been fixed and is again available for use.

AndyCr15
01-17-2020, 03:50 AM
Still says can't connect to servers.

Well, said this eventually. Keeps telling me my password is wrong... it's been so long, I can't remember. When I try and use the reset it says it's Password reset failed...

phalkon30
01-17-2020, 09:03 AM
Mine says sync failed, service error: -100 the database 'beyondpodsyncwest' has reached its size quota.

Still shows last sync as 2018.

KimW
01-17-2020, 09:48 AM
Mine says sync failed, service error: -100 the database 'beyondpodsyncwest' has reached its size quota.

Still shows last sync as 2018.

I am reporting this to the development team now. Yesterday when they fixed the server error, I was able to use EpisodeSync on 3 different devices with no issues, however when I saw these two messages of an error again, I logged out and tried to log back in and I am seeing the issues you both are seeing. I am going to have them dig back into this. I do apologize! It was indeed working yesterday when I posted it was. Hopefully they can resolve this quickly.

KimW
01-17-2020, 11:17 AM
@Phalkon30 @AndyCr15 Okay, the issue was the Quota had been met. Once I announced the fix, it seems everyone rushed to activate it again, understandably. There was always a quota on EpisodeSync, but they went ahead and raised that quota since it seems to have grown, and you should be able to log back in/reset your password with no issues.

If you do have an issue still, please let me know.

phalkon30
01-17-2020, 01:44 PM
@Phalkon30 @AndyCr15 Okay, the issue was the Quota had been met. Once I announced the fix, it seems everyone rushed to activate it again, understandably. There was always a quota on EpisodeSync, but they went ahead and raised that quota since it seems to have grown, and you should be able to log back in/reset your password with no issues.

If you do have an issue still, please let me know.

Appears to be fixed! It auto synced in the background about 30 minutes ago, no errors. Nice!

colonelheero
02-29-2020, 11:38 AM
The sync is working again but I think the behavior is sightly different. Not sure if this is just me or other also seeing the same issue: When I play something on device A, once I stop it will trigger a sync up to the server, and apply make any remote updates. That's good. But device B doesn't get the update until it play/stop something and trigger the sync itself. I'm positive in the past that the sync initialized by device A would wake up device B within a few seconds to perform the sync.

Pitprops
05-15-2020, 02:08 PM
Sorry to raise this again. I recently updated to 4.3.8 on 2 devices and activated episode sync on both. It has never worked. Looking at the logs on both devices I see sync failed. Server error -1, No value for type.

KimW
05-15-2020, 04:16 PM
Sorry to raise this again. I recently updated to 4.3.8 on 2 devices and activated episode sync on both. It has never worked. Looking at the logs on both devices I see sync failed. Server error -1, No value for type.

Hello,
Can you please send your BeyondPod, Android and Sync Logs to so we can take a look at your logs? Thank you.

To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" and "Sync" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

Please make sure to include a brief description of your issue with each log so development knows what report to match your logs to.

burbigo1
05-15-2020, 11:39 PM
The synch' is working great now an it's working as good and it did before this little issue.

shingcch
05-16-2020, 10:23 AM
I have a same issue of syncing two devices that only the first time successful synced. Later only got this error in sync log.