PDA

View Full Version : Beta 37 doesn't recognize cast canceled



derobert
09-13-2018, 12:04 AM
On the cast screen, tap the cast button. (Yeah, that's working again). Then press the back button. You get a dialog as if it were casting, with Disconnect and Stop Casting as options.

KimW
09-13-2018, 09:18 AM
On the cast screen, tap the cast button. (Yeah, that's working again). Then press the back button. You get a dialog as if it were casting, with Disconnect and Stop Casting as options.

Hello,

I'm not sure I quite understand the issue you are having. Can you please explain further? If you would like the casting to stop, you need to click "Stop Casting".

derobert
09-13-2018, 11:33 AM
Sorry, I didn't explain fully. I wasn't casting anything. I was listening to a podcast over the phone's speaker. I pressed the cast button, but did not chose a cast destination; instead I pressed the back button. So it was still playing locally, over the phone's speaker. But it displayed the dialog with Disconnect and Stop Casting as if it were casting. But it wasn't, it was playing over the phone's speaker.

I'll try and reproduce with screenshots if that isn't clear and/or isn't happening for you. I'm on a Nexus 6P running Android 8.1.

dlynch
09-13-2018, 05:58 PM
Indeed: once you've done any Casting, the Cast to dialog appears every time the main view gets focus (For example, display any episode's Notes and touch Back). Touching Back when the Cast to dialog is up gets you to the Casting dialog, in that funny state of BP isn't casting.

On the plus side, the Cast to dialog always send to work, no matter how it gets there.

I'm using a Pixel on Pie.

KimW
09-17-2018, 04:09 PM
Sorry, I didn't explain fully. I wasn't casting anything. I was listening to a podcast over the phone's speaker. I pressed the cast button, but did not chose a cast destination; instead I pressed the back button. So it was still playing locally, over the phone's speaker. But it displayed the dialog with Disconnect and Stop Casting as if it were casting. But it wasn't, it was playing over the phone's speaker.

I'll try and reproduce with screenshots if that isn't clear and/or isn't happening for you. I'm on a Nexus 6P running Android 8.1.

Are you still seeing this behavior in v4.2.38?

derobert
09-17-2018, 05:21 PM
I believe so. Will double-check once I'm home later tonight (no cast devices at work)

derobert
09-19-2018, 07:49 AM
I double-checked; still happening with .38. Logs emailed.

dlynch
09-19-2018, 05:06 PM
Sorry I didn't mention that my experience is with .38. I never had .37 installed.

derobert
09-24-2018, 02:53 PM
I confirm .39 fixed this for me.