Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43

Thread: Podcasts showing up in Google Music

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    Mar 2013
    Posts
    11

    Podcasts showing up in Google Music

    I have sharing with Google Music disabled. I saw some other posts about .nomedia files, but I wasn't sure if I should be messing with that. How can I make the podcasts invisible to Google Music?

  2. #2
    Junior Member
    Join Date
    Mar 2013
    Posts
    11
    I am using 3.1.10 on my Galaxy Nexus CyannogenMod 10M2

  3. #3
    BeyondPod Team
    Join Date
    Feb 2012
    Posts
    1,033
    On some newer devices (running Jelly Bean 4.2 and later) you may have to put a .nomedia file also in: /storage/emulated/legacy/BeyondPod folder as this is another place that Music is looking for.

    You can see more information here: http://www.beyondpod.com/forum/showt...d-Google-Music.

  4. #4
    Junior Member
    Join Date
    Mar 2013
    Posts
    11
    Quote Originally Posted by StefanK View Post
    On some newer devices (running Jelly Bean 4.2 and later) you may have to put a .nomedia file also in: /storage/emulated/legacy/BeyondPod folder as this is another place that Music is looking for.

    You can see more information here: http://www.beyondpod.com/forum/showt...d-Google-Music.
    Thanks a lot for the response. That was the post I had originally read. I did put an empty .nomedia file in that directory and refreshed google music but that didin't help. All of those dirs appear to be symlinks to the same place.
    However, I'd prefer not to have to mess with the filemanager to do this. This seems like a bug in the implementation of the "Do not share with Google Music"
    Any other way to work around this?

    Thanks.

  5. #5
    BeyondPod Team
    Join Date
    Feb 2012
    Posts
    1,033
    What is in this post is the only known workaround at this time. The problem is that Android actively looks for new files and adds them to the music collection and the only way to stop it is to add .nomedia files to the folders you want to ignore. Internally BeyodnPod does exactly that when you uncheck "Share Podcasts" setting.

    Keep in mind that adding .nomedia file will prevent adding of new files but will not remove the existing files until the media database is rebuilt. In order for files to be removed, you have to add the .nomedia file and rebuild the media database.

    Rebuilding generally happens when the device is restarted (during boot) but you can also rebuild it following the steps in this post: https://forums.motorola.com/posts/cf07acdc3a

    Stefan

  6. #6
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Quote Originally Posted by jjrussell View Post
    I did put an empty .nomedia file in that directory and refreshed google music but that didin't help. All of those dirs appear to be symlinks to the same place.
    However, I'd prefer not to have to mess with the filemanager to do this. This seems like a bug in the implementation of the "Do not share with Google Music"
    Any other way to work around this?
    Manually adding .nomedia IS the workaround. That's what BP does behind the scenes to prevent Google Music from seeing podcasts. However, the recent JB changes have shifted the goalposts by adding symlinks to the old paths, and it appears that all the symlinks need their own .nomedia files. It may be that there are other symlinks that Google Music is using. Alternatively, clearing Google Music's cache, or Refreshing music (in Music's own settings) may help.

    Julie

  7. #7
    Junior Member
    Join Date
    Mar 2013
    Posts
    11
    Ah, the clearing of the Media Storage data was the part that I was missing. I had added the .nomedia file but I selected refresh library from the google music app which isn't the same as clearing the Media Storage.
    All of the beyondpod stuff is gone from music player now.

    Thanks for the help.

  8. #8
    Senior Member
    Join Date
    Mar 2012
    Location
    San Francisco Bay Area
    Posts
    252
    Quote Originally Posted by juwlz View Post
    Manually adding .nomedia IS the workaround. That's what BP does behind the scenes to prevent Google Music from seeing podcasts. However, the recent JB changes have shifted the goalposts by adding symlinks to the old paths, and it appears that all the symlinks need their own .nomedia files. It may be that there are other symlinks that Google Music is using. Alternatively, clearing Google Music's cache, or Refreshing music (in Music's own settings) may help.
    Trying to add additional .nomedia files in linked paths won't have any effect, since all such links point to the same place.

    Quote Originally Posted by StefanK View Post
    What is in this post is the only known workaround at this time. The problem is that Android actively looks for new files and adds them to the music collection and the only way to stop it is to add .nomedia files to the folders you want to ignore. Internally BeyodnPod does exactly that when you uncheck "Share Podcasts" setting.
    Keep in mind that adding .nomedia file will prevent adding of new files but will not remove the existing files until the media database is rebuilt. In order for files to be removed, you have to add the .nomedia file and rebuild the media database.
    What a .nomedia file seems to do is prevent old episodes from being added to Music during a media scan.

    The problem (here at least) isn't old episodes -- it's new downloaded episodes. What seems to be happening is that they get added as a result of download rather than media scan, so the .nomedia file has no effect.

    It's a very annoying problem that needs to be fixed soon because it makes the Recent tab in Music nearly useless. The work-around of deleting and rebuilding the Media database has the downside of screwing up phone audio settings.

    Thank you.
    Device model: Nexus 4
    Android version: 4.2.2 (JDQ39)
    Carrier: T-Mobile USA
    Last edited by JNavas; 03-26-2013 at 06:17 PM.
    Hope that helps,
    John
    [Nexus 5 running Lollipop 5.1 on T-Mobile USA]

  9. #9
    Junior Member
    Join Date
    Jun 2013
    Posts
    29

    Google could fix this easily

    Quote Originally Posted by jjrussell View Post
    Thanks a lot for the response. That was the post I had originally read. I did put an empty .nomedia file in that directory and refreshed google music but that didin't help. All of those dirs appear to be symlinks to the same place.
    However, I'd prefer not to have to mess with the filemanager to do this. This seems like a bug in the implementation of the "Do not share with Google Music"
    Any other way to work around this?

    Thanks.
    Google could fix this easily by just giving us the option to choose which folders (or folder names) it would search in its apps. For Music, it could just use the Music folder (standard on stock Android, typical on most devices). The problem also happens with the Gallery app; it shows all of my album artwork even though it's in its own folder outside of the camera folders (DCIM). Really, this folder should just be called "Camera" or "Pictures". Frankly I'd love to see a separate Screenshots folder too.

    Google has been dropping the ball with media on Android for years. I don't understand why they haven't been able to figure this out. iOS (iPhone and iPad) are not perfect, but they're way better than what Google does.

    If they just added an option to let us choose which folder to use for the app, that would solve all of these problems.

  10. #10
    Senior Member
    Join Date
    Mar 2012
    Location
    San Francisco Bay Area
    Posts
    252
    Quote Originally Posted by dhinged View Post
    Google could fix this easily by just giving us the option to choose which folders (or folder names) it would search in its apps. For Music, it could just use the Music folder (standard on stock Android, typical on most devices). The problem also happens with the Gallery app; it shows all of my album artwork even though it's in its own folder outside of the camera folders (DCIM). Really, this folder should just be called "Camera" or "Pictures". Frankly I'd love to see a separate Screenshots folder too.

    Google has been dropping the ball with media on Android for years. I don't understand why they haven't been able to figure this out. iOS (iPhone and iPad) are not perfect, but they're way better than what Google does.

    If they just added an option to let us choose which folder to use for the app, that would solve all of these problems.
    With respect, this is a problem of using the media scanner for a purpose that was not intended and defined, not any sort of failure by Google.
    Hope that helps,
    John
    [Nexus 5 running Lollipop 5.1 on T-Mobile USA]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •