Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: No longer properly adds RSS feed

  1. #1
    Junior Member
    Join Date
    Jul 2013
    Posts
    2

    No longer properly adds RSS feed

    I just installed a new ROM and tried to add one of my favorite podcasts. Unfortunately, when I give it the RSS feed, instead of loading the associated mp3s it simply loads them as news stories and thus only text. About a month ago I did this for the same one without problem.

    Here is the feed: http://trancitweekly.blogspot.com/feeds/posts/default

    Please fix this!

  2. #2
    BeyondPod Team
    Join Date
    Feb 2012
    Posts
    1,033
    It looks like the publisher has changed the feed format since you subscribed last. They no longer include episodes as "podcasts". Instead the feed has a link to the episode directly in the post message. In order to be recognized as a "podcast" the link has to exist in a "enclosure" or "media" section of each post. Your best bet is to contact the publisher and ask them to adjust the software that generates the feed so it includes the download link as a "podcast". My guess is that this is just a simple miss configuration on their side (or they may have a different feed that is formatted as a podcast).

  3. #3
    Junior Member
    Join Date
    Jul 2013
    Posts
    2
    Alright, he sent me a link which was formatted properly from feedly. Is it possible to add more adaptive methods to finding podcast feeds? It would seem possibly to parse such information from a page.

  4. #4
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    In general, updated podcast feeds do get updated in BeyondPod's database, but it may take a few weeks for it to happen after a change is made.

    If you click on a feed in a website, then BP will use exactly the feed you click on (it's up to the owner of the site to make sure the link is correct). If you search in BeyondPod, a number of different methods are used to find feeds from the data you enter, including, but not restricted to, searching BeyondPod's own database.

    Julie

  5. #5
    I'm having this same problem with my own Podcast. I just did a phone format and didn't back up my podcasts. In the process of going back to add them all in some of them are showing as articles as described. For my own personal podcast I have not changed anything on the back end and the podcasts are still hosted on that feed.

    http://communitypodcastunlocked.podbean.com/feed/

    Any help would be amazing.

  6. #6
    Senior Member
    Join Date
    Mar 2012
    Location
    Boston area
    Posts
    861
    That URL loads properly with BP 3.10.45, and Firefox displays it well. All episodes show as downloadable, and I downloaded one just to check.

    What BP version, platform, and Android version are you running?

  7. #7
    Quote Originally Posted by Dennis Rockwell View Post
    That URL loads properly with BP 3.10.45, and Firefox displays it well. All episodes show as downloadable, and I downloaded one just to check.

    What BP version, platform, and Android version are you running?
    3.1.39, galaxy nexus, 4.2.2

    Seems like I need to update bp. How do I do that if the play store doesn't say I need an update?

  8. #8
    Senior Member
    Join Date
    Mar 2012
    Location
    Boston area
    Posts
    861
    See the beta forum post for the details.

  9. #9
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Version 3.x.45 (x=1 for phone; x=10 for tablet) is available to side load from the beyondpod.com website.

  10. #10
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    However, nothing in this area of the code has changed in recent versions, so:


    1. Make sure that the feed settings (and/or default feed settings) are NOT set to "Ignore all Episodes"
    2. If that's not the case, try deleting the feed, and adding it by clicking on the URL in this thread. That's worked for everybody else ;-).


    Julie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •