Results 1 to 4 of 4

Thread: Enabled Sync on 2 devices, now I get "Beyondpod failed to start"

  1. #1

    Enabled Sync on 2 devices, now I get "Beyondpod failed to start"

    Here's the error message I get:

    Code:
    BeyondPod failed to start
    
    Not allowed to start service intent { act=com.google.android.c2dm.intent.REGISTER
    pkg=com.google.android.gsf (has extras) } without permission
    com.google.android.c2dm.permission RECEIVE
    
    BeyondPod will now Exit!
    Running on CM11, on a Barnes & Noble Nook HD+.

    Only happened 5 minutes after I enabled/logged into my account, and turned on episode sync. Only BeyondPod is throwing off errors.

    Thoughts? TIA!

  2. #2
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Hi, and welcome to the forum.

    Are you getting the same on the other device you're syncing with (and what is it?)?

    Julie

  3. #3
    Quote Originally Posted by juwlz View Post
    Hi, and welcome to the forum.

    Are you getting the same on the other device you're syncing with (and what is it?)?

    Julie
    Hi Julie,

    Here's where things stand now.

    I uninstalled BP on the tablet, reinstalled, and it came right back up, without episode sync configured (as you'd expect).

    This time, I've started syncing, and it isn't crashing the tablet. I'll report back when I delete a common episode on my phone and vice versa.

    The other device is my GS3 running stock 4.1.2, and it's had no adverse effects.

    Thanks for checking in!

  4. #4
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Research suggests that it seems to be something to do with with the device (Nook) running CM11.

    It is caused by Google Cloud Messaging (which BP uses to notify devices when the other device uploads sync changes) – it complains that there is no permission and refuses to start BP. Our side is set correctly, but for some reason either the Nook or CM11 can’t recognize that.

    Googling shows that this occasionally pops up as an issue, but nobody knows why it is happening nor how to solve it. Some people were able to work around it by creating Google account on the device (it there is no such account) some by uninstalling and reinstalling.

    Sorry we can't be more help, but glad it's working for you now.

    Julie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •