Results 1 to 2 of 2

Thread: WIFI times out and stops podcast stream

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Location
    Colorado
    Posts
    1

    WIFI times out and stops podcast stream

    I couldn't find the answer to this question anywhere, and the "custom sleep timeout" option doesn't seem to help.

    First, I have my HTC One set to "keep wifi turned on during sleep only when plugged in" to save battery when I'm not using it.

    As a result, when I am STREAMING a BP podcast it always stops right at 15 minutes -- presumably because my wifi connection disconnected. In these cases I had initially started the podcast by hitting 'play' and then manually turning off the HTC screen with power button.

    I would think Android would be smart enough to realize the phone is not in sleep mode if audio is playing, and hence keep the wifi turned on.

    Questions: Is the "custom sleep timeout" somehow supposed to keep phone from going into sleep mode, or am I misunderstanding it? Is there another way to keep the wifi from disconnecting? Would this not happen if I download the episode instead of stream it (which I haven't tried, and would prefer not to do)?

    I can't believe I am the only one who would have this issue. I do not want to choose to keep the screen on at all times just to keep the wifi on.

    Thanks,
    Chris

  2. #2
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    I've had intermittent disconnections when playing via Chromecast, but I don't think it's related to WiFi timeouts on the device. Mine have been much more random - sometimes immediately on connection, sometimes after 15-30 minutes. At other times, I've listened to a playlist of various episodes from various publishers for nearly 2 hours without any problems. I don't manually switch the screen off, but it'll certainly time out after a couple of minutes anyway. I have Keep WiFi on during sleep set to Always.

    Next time you're casting, could you try setting Advanced WiFi Settings to "Keep WiFi on during sleep - Always" (or keep your device plugged in) to confirm whether that is indeed the issue.

    If it is, I'm not sure whether keeping WiFi on would be the responsibility of BeyondPod or the built in Music Player. One way to check would be to use Google Music for playback and see if you get the same problem. If you do, it could be (in no particular order)
    1. expected Android behaviour
    2. a bug in the AOSP player
    3. a bug in HTC's implementation of the player
    4. BeyondPod not preventing the WiFi sleep

    Julie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •