Results 1 to 7 of 7

Thread: BeyondPod keeps playing after bluetooth disconnect

  1. #1
    Junior Member
    Join Date
    Dec 2013
    Posts
    4

    BeyondPod keeps playing after bluetooth disconnect

    I just upgraded to Android 4.4.1 on my Nexus 4, and noticed that:
    • if the screen is locked, and
    • I disconnect my bluetooth headphones
    the audio starts playing out of the phone's speaker rather than pausing like it did in 4.4 and below.

    If I do this when the screen is on, it pauses like normal.

    When it's still playing after a disconnect, I can't play/pause using any controls, I've tried:
    • reconnecting bluetooth and pressing pause on the headphones
    • play controls on the lock screen
    • play controls in the notification area
    • play controls in beyondpod itself
    and in all cases it keeps going. The only way to stop it is to terminate the beyondpod process (e.g. bringing up the recent apps list and swiping it off.)

    These controls work if I do them before a disconnect.

  2. #2
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Hi and welcome to the forum.

    Does the thing happen when you're using Google music?

    Julie

  3. #3
    Junior Member
    Join Date
    Dec 2013
    Posts
    4
    Quote Originally Posted by juwlz View Post
    Does the thing happen when you're using Google music?
    Hi Julie,

    I just checked with Google Music and it behaves correctly: on disconnecting the bluetooth headset with a locked (and unlocked) screen, it pauses.

  4. #4
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Do you have speed adjustment enabled (even if you're playing at x1)?

    If so, does disabling it (Menu | More... | Settings | Player Settings | Playback speed and untick Enable speed adjustment) make any difference?

  5. #5
    Junior Member
    Join Date
    Dec 2013
    Posts
    4
    Quote Originally Posted by juwlz View Post
    Do you have speed adjustment enabled (even if you're playing at x1)?
    I had speed adjustment enabled and set to 1x, and disabled it according to your instructions. A quick test now suggests it fixed the issue, but I'll test it more tomorrow.

    It might be of note that prior to doing this, I ended up in a state where the bluetooth controls wouldn't pause it. This was followed (after killing BeyondPod, and resuming it, then a few minutes) by a total bluetooth shutdown requiring a reboot. Both my headphones and my pebble smartwatch disconnected, and bluetooth would not reenable from power tools. This looks more like a 4.4.1 bug than a BeyondPod bug however. I don't remember if it kept playing on speaker or not when this happened though. I think it didn't.
    Last edited by eythian; 12-08-2013 at 06:47 AM.

  6. #6
    Junior Member
    Join Date
    Dec 2013
    Posts
    4
    This is definitely still happening, I just caught it then. It doesn't seem to always happen however.

  7. #7
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    I'm guessing that the signal that says the Bluetooth has been disconnected isn't reaching BeyondPod.

    The only way we'll find out is to get an Android log immediately after you get the problem.

    To do that, next time it happens, unlock your phone, open BeyondPod, and go to Menu | More... | Settings | Menu (again) | View Logs | Android log. From there you'll find an option to email the log to support in the menu. Please include details in the email message about what you did and what happened (that the phone was (presumably) locked, whether the playback continued via the speaker, a link to this thread and your forum name).

    Julie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •