Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Upon resuming playback, the player jumps back (almost) to the beginning of episode

  1. #1
    Junior Member
    Join Date
    Feb 2014
    Posts
    12

    Upon resuming playback, the player jumps back (almost) to the beginning of episode

    As per subject: As of lately, strange things happen, when I pause an episode, and later resume playback, maybe after having listened to other podcasts in the meantime.

    When I check the episode list, the bar still indicates the position where I stopped, but as soon as I press the play button, playback resumes from a completely different position, much earlier in the podcast. This behaviour does not occur every single time, but most of the time.

    Has anyone else seen something similar happen? Any known remedies?

  2. #2
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Is there any pattern to which episodes this is happening with?
    e.g. Is it only with streamed episodes? Is it only with episodes from some feeds? A combination of the two?

  3. #3
    Junior Member
    Join Date
    Feb 2014
    Posts
    12
    Quote Originally Posted by juwlz View Post
    Is there any pattern to which episodes this is happening with?
    e.g. Is it only with streamed episodes? Is it only with episodes from some feeds? A combination of the two?
    The only clearly discerneable pattern is, that it occurs if I wait a while and resume listening later. If I stop and beyondpod remains in the foreground and then I resume after a short while, it continues at the correct position.

    Regarding streamed vs. download, I rarely use streaming at all. My observations are about downloaded episodes. It applies to all feeds equally.

    I recently switched from an old HTC Desire Z / Vision phone with Cyanogenmod to a fairphone device running their customized version of Android 4.2.2. I don't think the troubles began immediately after that. My recollection is that first, beyondpod worked just fine on the new device and started misbehaving after a while, but it might also be that it took me a while to notice the pattern, not sure.
    Last edited by Alta; 11-03-2014 at 04:43 AM. Reason: added info

  4. #4
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    What version of BeyondPod are you running? If you're still on BP 3.x, 4.0 is rolling out in the Playstore, and everybody should get it soon if you haven't already. If you're still getting the same problem with that, please post again, and I'll talk you through getting some logs that might help identify what the problem is.

    Julie

  5. #5
    Junior Member
    Join Date
    Feb 2014
    Posts
    12
    still on 3.x

  6. #6
    Junior Member
    Join Date
    Feb 2014
    Posts
    12
    Quote Originally Posted by juwlz View Post
    What version of BeyondPod are you running? If you're still on BP 3.x, 4.0 is rolling out in the Playstore, and everybody should get it soon if you haven't already. If you're still getting the same problem with that, please post again, and I'll talk you through getting some logs that might help identify what the problem is.

    Julie
    Julie, thanks for your offer! I now have 4.0 and the situation is very much unchanged.

  7. #7
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    Next time this happens (obviously it's easier if you can reproduce it at will!), let's get an Android log and a BeyondPod log of what happened. As a combination, hopefully we can track down what's happening.

    Don't be afraid to send in multiple pairs of logs if it happens more than once. Sometimes it takes more than one to spot a pattern.

    To get the logs, immediately after you get the problem, go to Settings (bottom of left hand drawer), then press Three dots Menu, and choose View Logs...
    First choose Android Log, and from there Menu again to Email support. Please include a brief description of the problem, and link to (or the name of) this forum thread, and your forum name.
    Then repeat, but this time choose BeyondPod log. Again, include a brief description etc. as above.

    Let's hope we can see what's going wrong.

    Julie

  8. #8
    Junior Member
    Join Date
    Nov 2014
    Posts
    4
    I have exactly the same Problem. It usually occurs when I pause a podcast, listen to another podcast or fiddle around with the playlist and then resume playback of the first cast.

  9. #9
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    The more logs we can get, the better, until we can work out what's causing it and fix it.

  10. #10
    Junior Member
    Join Date
    Jun 2012
    Posts
    11
    For at least a year now, on all three of my phones, including Galaxy S2 and Nexus 5, the seeking has malfunctioned. It has only been getting worse in recent months. I have upgraded to 4.0 trying to fix this, in vain. None of the suggestions in the FAQ have made a difference. This annoys me almost every time I use the app, so I'm forced to switch to something else that gets right this basic requirement of a podcast player.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •