Results 1 to 4 of 4

Thread: Update problem

  1. #1

    Exclamation Update problem

    Hi,
    I've been using BeyondPod for years and am very happy with it. I have a Galaxy Note 4 and see that 4.1.20 has multi-window support so I updated. I made a backup of the settings before via Backup and Restore.
    I had problems with the update (comming from 4.0.32 since I had previously had problems with 4.1.14 and gone back). I decided to uninstall BeyondPod, delete downloaded episodes and all that and install, first from the play store and was planing on updating to 4.1.20 and test multi-window. In 4.1.18 I restored the backup from 4.0.32 and here is where things start getting weird.
    Now the screen has <N/A> in the top gray bar (category name I think), and I cannot add feeds or categories. If I try to add a feed it goes through all the steps and the feed doesn't get added. Or at least I can't see it. Also, every time I start BeyondPod now it goes to the welcome screen (Let's start).

    Here are the steps I took since I'm probably doing something wrong in one or more of them. This is on my device after uninstalling BP. I do have the Key installed.
    Installed BeyondPod from play store
    Open BeyondPod
    Press "Let's Start"
    Press "Skip This"
    Press hamburger and go into settings
    Press Backup and Restore
    Select new backup location (/storage/emulated/0/backups)
    Press Restore (select 2014-12-23, I have 2 other older backups and they both give same behaviour)
    Press Continue and BP restarts
    Now I'm faced with "Configured episode download location is no longer available!" If I press Cancel the app closes, if I press Switch i go back to the "Let's start" screen and am in the situation described above.

    I can send you my backup file if that helps. At this point all I want is my feeds back so I don't have to resubscribe to my 70-80 feeds.

  2. #2
    BeyondPod Team
    Join Date
    Aug 2014
    Posts
    109
    Can you email the backup file to support@beyondpod.mobi and put a link to this thread in the body of the email?

    Thanks
    Bill

  3. #3
    Junior Member
    Join Date
    Sep 2013
    Posts
    3
    There appears to be a Samsung/TouchWiz bug that causes that and affects only a few Samsung models with 4.2.2:
    http://developer.samsung.com/forum/b...ssageId=248142

    12/27/14 9:24:03 AM: BeyondPodApplication (4.1.21) - !!! Unhandled exception !!! Reason: [ java.lang.NoClassDefFoundError ] android.support.v7.internal.view.menu.MenuBuilderj ava.lang.NoClassDefFoundError: android.support.v7.internal.view.menu.MenuBuilder
    at android.support.v7.app.ActionBarActivityDelegateBa se.initializePanelMenu(ActionBarActivityDelegateBa se.java:914)
    at android.support.v7.app.ActionBarActivityDelegateBa se.preparePanel(ActionBarActivityDelegateBase.java :964)
    at android.support.v7.app.ActionBarActivityDelegateBa se.doInvalidatePanelMenu(ActionBarActivityDelegate Base.java:1182)
    at android.support.v7.app.ActionBarActivityDelegateBa se.access$100(ActionBarActivityDelegateBase.java:7 9)
    at android.support.v7.app.ActionBarActivityDelegateBa se$1.run(ActionBarActivityDelegateBase.java:115)
    at android.os.Handler.handleCallback(Handler.java:725 )
    at android.os.Handler.dispatchMessage(Handler.java:92 )
    at android.os.Looper.loop(Looper.java:176)
    at android.app.ActivityThread.main(ActivityThread.jav a:5299)
    at java.lang.reflect.Method.invokeNative(Native Method)
    at java.lang.reflect.Method.invoke(Method.java:511)
    at com.android.internal.os.ZygoteInit$MethodAndArgsCa ller.run(ZygoteInit.java:1102)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:869)
    at dalvik.system.NativeStart.main(Native Method)

  4. #4
    As it turned out, it was a dirty uninstall. After cleaning all BeyondPod from the sd card manually the update and restore worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •