Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: Strange numeric-suffixed episode names; incomplete update? (no log)

  1. #11
    Junior Member
    Join Date
    Mar 2015
    Posts
    12
    Quote Originally Posted by juwlz View Post
    @sorh

    To determine what's happening, we really need to get an Android log of the problem happening (as per my last post).

    Julie

    It's inside the attached zip file Julie.

  2. #12
    Junior Member
    Join Date
    Mar 2015
    Posts
    12
    Any updates?

  3. #13
    BeyondPod Team
    Join Date
    Feb 2012
    Posts
    1,033
    I looked at the logs and could not find anything unusual - episodes seem to have downloaded correctly. The numbers you see are actually the names of the downloaded file as they are on the SD card.

    The way it internally works is that once the episode is downloaded, BeyondPod tries to retrieve the "title" from the file itself (For this purpose it uses a component from Android called MediaMetadataRetriever that internally read the ID3 Tile tags from the downloaded file itself).

    If for some reason it can't read the title from the file it will use the file name instead. My guess is that for some reason from time to time this Android component can't read the file name correctly so it reverts to using the file name. One possibility is that there is some issue with the External SD card you are using. You can try to move everything back to the Internal SD card and see if that fixes the issue.

  4. #14
    Junior Member
    Join Date
    Mar 2015
    Posts
    12
    You may be right but then why the titles show up incorrectly from the beginning on the "updade and download queue" window when updating by schedule and show up correctly when manual update is asked?
    If the problem was on my external sd shouldn't it fail on manual update too?Shouldn't it cause more issues with any other apps and files?
    I'll give it a try and use internal then just to check it out.
    Kind regards.

    pls check atached pictures, scheduled vs manual.
    plus I've noticed that on scheduled time, it is updating but no icon is shown in status bar.
    Attached Images Attached Images
    Last edited by sorh; 04-13-2015 at 04:36 PM.

  5. #15
    Junior Member
    Join Date
    Mar 2015
    Posts
    12
    Quote Originally Posted by StefanK View Post
    I looked at the logs and could not find anything unusual - episodes seem to have downloaded correctly. The numbers you see are actually the names of the downloaded file as they are on the SD card.

    The way it internally works is that once the episode is downloaded, BeyondPod tries to retrieve the "title" from the file itself (For this purpose it uses a component from Android called MediaMetadataRetriever that internally read the ID3 Tile tags from the downloaded file itself).

    If for some reason it can't read the title from the file it will use the file name instead. My guess is that for some reason from time to time this Android component can't read the file name correctly so it reverts to using the file name. One possibility is that there is some issue with the External SD card you are using. You can try to move everything back to the Internal SD card and see if that fixes the issue.
    Using internal SD right now. Exactly the same issue.
    Other thing I've noticed about the strange titles is that the names can be actually shown correctly when I change the view from "my episodes" to "all published"
    Attached Images Attached Images

  6. #16
    BeyondPod Team
    Join Date
    Feb 2012
    Posts
    1,033
    The only explanation that I can come up with is that for some reason your device can't extract the metadata from the file from time to time.

    Can you please share the feed URL/episode that this is happening and a set of steps that cause this to happen. If I can replicate it on one of my test devices, then there should be a way to fix it (assuming this is not a device specific issue).

  7. #17
    Junior Member
    Join Date
    Mar 2015
    Posts
    5
    Update: several days ago, I tried checking "Toggle WiFi on Update" in the Feed Update Settings. Since then (knock silicon) the problem has not recurred. (FWIW, I already had "Download on WiFi Only" checked, and "Use Mobile Data" unchecked -- though those two seem redundant with each other). sorh, how are your update options set?

  8. #18
    Junior Member
    Join Date
    Mar 2015
    Posts
    12
    I actually didn't mind a lot about those "strange filename numbers"..
    My issue is that episodes get cutted like the download wasn't made til the end.
    Because everytime it happens, they got those strange names, I guess it has something to do with.
    Attached are my configurations and feeds list.
    Attached Images Attached Images
    Attached Files Attached Files

  9. #19
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK, http://blog.juwlz.co.uk/
    Posts
    4,169
    Quote Originally Posted by dlosisek View Post
    I already had "Download on WiFi Only" checked, and "Use Mobile Data" unchecked -- though those two seem redundant with each other
    To explain that:

    • The Download setting governs what you use for downloading episodes (hi data volume)
    • Use Mobile Data governs whether you want BP to at least update feeds on mobile, even though you're not downloading them (low data volume)

    Julie

  10. #20
    BeyondPod Team
    Join Date
    Feb 2012
    Posts
    1,033
    If you find that the issue is related to an incomplete download (which is quite possible), then strange part is that maybe the server (or some network equipment in the middle) causes a partial download to occur, but BeyondPod can't detect it.

    When BeyondPod downloads a file, it asks the server for the total file size and then compares it with the file size on the device. If the local file is smaller, it knows it has not downloaded the entire file and indicates that "partially downloaded" file by showing the download progress "paused" like this: Screenshot_2015-04-20-10-24-19.jpg

    If you don't see episode as "partially downloaded", BP thinks it was downloaded completely (downloaded file size is the same as server reported file size).

    I also found that episodes (at least the ones I tried) of TSF FORUM feed, do not have correct ID3 metadata - for some reason instead of using the "Title" to store episode name, they use "Comment" so this explains why BP can't read the title from the file. Generally, when BP can't read the title, it will use the post title from the feed - this explains why you see titles for some episodes - they come from the post itself.

    Something (network, or some other issue) must be happening from time to time during download that breaks the normal flow resulting in those "broken" episodes. I have set the TFS FORUM feed to download automatically on my device and will see if it happens here too and then try to catch what may be going on.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •