Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Buggy playback on Android Nougat

  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    3

    Buggy playback on Android Nougat

    Love the app guys.

    Unfortunately after updating to Android Nougat, I've started to have two problems:

    1. The app no longer properly remembers where I stopped listening on a podcast, and picks-up playing again from earlier in the episode. Also odd is that when I'm playing, the location bar doesn't move, and the seconds don't count up or down.

    2. The app has started occasionally skipping to the next podcast on my list before the current podcast is finished. This is typically only in the last little bit of the previous podcast.

    I'm running Android Nougat on a Oneplus 3, and usually playback at 1.4x speed.

  2. #2
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    What version of BeyondPod are you running?

  3. #3
    Junior Member
    Join Date
    Dec 2016
    Posts
    3
    I'm running version 4.2.16.

  4. #4

  5. #5
    BeyondPod Team
    Join Date
    Mar 2012
    Location
    UK (BP Team member from Jun 2012 to Mar 2017), http://blog.juwlz.co.uk/
    Posts
    4,169
    From a quick scan of those, it seems that the issue is related to anything that adjusts the underlying playback (volume boost, speed adjustment, etc.)

    It appears that there's something broken in the built-in Android audio players in Nougat. Of course, Google Music doesn't have speed adjustment or volume boost settings, or you could test with that.

    Julie

  6. #6
    I just got nougat on my Axon 7, and BP (4.2.18) has been consistently skipping the last two minutes or so of downloaded podcasts. I normally listen at 1.4-1.2x.

    They play OK in VLC.

    Unchecking "Enable Sonic Player" in the advanced settings screen seems to be a functional work-around, at least so far. This loses variable speed playback.

    Normal speed playback sounds sooo weird!

  7. #7
    Junior Member
    Join Date
    Feb 2017
    Posts
    5
    I'm using the same phone with the same version of Beyondpod, and am experiencing the same problem. At 1.5x playback speed is not updating the progression of the podcast. This worked fine yesterday until I updated to Nougat. 1.5x playback works OK as long as I don't have to pause or fast forward. It will fast-forward from the last updated place in the podcast, or restart from where you originally started and basically forgets what your progress was. If for some reason I have to pause, then I must hunt through the podcast manually to try and find where I left off. So at this point, I just don't stop and avoid using the forward/reverse buttons.

    Amazing program otherwise, and honestly this is the first issue I've ever had with it.
    Last edited by Trailmyx; 02-08-2017 at 03:34 PM.

  8. #8
    I was able to get variable speed playback back by using Maple Player (Either Classic or JB work) by SQR5 as an external player.

    Using an external player does mean that I have to restart smartplay after each podcast ends, so having a smartplay shortcut on my home screen is a big help.

  9. #9
    Junior Member
    Join Date
    Feb 2017
    Posts
    1
    I have same problem - running BP 4.2.16. Upgraded to Nougat a couple days ago on ZTE Axon 7. When playing podcast, the position indicator never changes. Didn't seem to matter whether I listened at 1x or 1.5x speed. I also encountered situation today that episode ended a few minutes early and skipped to next one. Deleted cache and all data - still same issue.

    I agree with Trailmyx - been using BP for years - great application!

  10. #10
    Quote Originally Posted by niprutyaj View Post
    I have same problem - running BP 4.2.16. Upgraded to Nougat a couple days ago on ZTE Axon 7. When playing podcast, the position indicator never changes. Didn't seem to matter whether I listened at 1x or 1.5x speed. I also encountered situation today that episode ended a few minutes early and skipped to next one. Deleted cache and all data - still same issue.

    I agree with Trailmyx - been using BP for years - great application!
    Add me to the list - Axon 7, BP 4.2.18. Also getting a lot of static on playback, both on bluetooth headphones and internal speakers. I agree with Julie, it seems to be some sort of conflict between internal player and Nougat's implementation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •