Aww man, AndroidPolice RSS feed now has this error in BeyondPod. I wonder if it's related to them moving to HTTPS on their website?

I wanted to avoid the new beta, but I'm wondering if I'll have to migrate now.