Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: ProtocolException on valid RSS feed

  1. #11
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by join3r View Post
    Hello,

    I'm having issues with the feed https://www.pseudocast.sk/feed/podcast/
    This feed validates on w3c and castfeed as a valid RSS feed.

    The error I receive is:
    Update failed!

    ProtocolException - Expected ':status' header not present

    I believe this to be an bug in the BeyondPod app.

    Anyone else experiencing similar issues or can look into it? Is there any publicly available bugtracker?
    Hello,

    When testing on the same devices and version of BP and Android as you reported, the error I receive is "Unable to connect to the feed's website. The feed address may be invalid or the website may have temporary connectivity issues."

    So this is looking to be a feed connection problem. Could you send your BeyondPod log to me in a PM here in the forum to take a look? Thank you!

  2. #12
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by tompson View Post
    Listeners of my Podcast at https://dtr.fm experience the same issue when using BeyondPod version v4.2.16 - can reproduce this on my Galaxy S6 when parsing https://dtr.fm/feed/mp3
    Hello,

    When testing on the same device and version of BP and Android as you reported, the error I receive is "Unable to connect to the feed's website. The feed address may be invalid or the website may have temporary connectivity issues."

    So this is looking to be a feed connection problem. Could you send your BeyondPod log to me in a PM here in the forum to take a look? Thank you!

  3. #13
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by Alan View Post
    Trying to use that feed URL is what brought me here. I've the same error, running v4.2.16 on Android 8.1.0 on Nexus 6P. I'd be glad to provide more detailed logging or other info, or try a Debug setting, if those would help either fix BeyondPod or confirm whether it's an issue with the feed source (though I could do that part if I made a little time to look into it).

    Thank you for posting, jurgenhaas.

    Alan
    Hello Alan and @jurgenhaas,

    I am unable to reproduce your issue using both versions of Android on multiple devices. I am able to access and subscribe to the feed using https://feeds.pacific-content.com/commandlineheroes without any issues.

    If you want to send your BeyondPod log to me in a PM here in the forum, we can take a look to see if we can find why you are having issues. Thank you!

  4. #14
    Junior Member
    Join Date
    Feb 2018
    Posts
    1
    I'm having the same issue with that exact feed. The feed will load, and I can stream the episodes, but I can't download them. I'll gladly PM my log. (How do I export the log?)

  5. #15
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by jc00ke View Post
    I'm having the same issue with that exact feed. The feed will load, and I can stream the episodes, but I can't download them. I'll gladly PM my log. (How do I export the log?)
    The development team was able to reproduce this issue with the Command Line Heroes feed (and a few others) and a fix was made and tested. This will be included in the next release coming soon.

  6. #16
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by join3r View Post
    Hello,

    I'm having issues with the feed https://www.pseudocast.sk/feed/podcast/
    This feed validates on w3c and castfeed as a valid RSS feed.

    The error I receive is:
    Update failed!

    ProtocolException - Expected ':status' header not present

    I believe this to be an bug in the BeyondPod app.

    Anyone else experiencing similar issues or can look into it? Is there any publicly available bugtracker?
    The development team was able to reproduce this issue with the feed you reported (and a few others) and a fix was made and tested. This will be included in the next release coming soon.

  7. #17
    Junior Member
    Join Date
    Feb 2018
    Location
    Sydney, Australia
    Posts
    1
    Quote Originally Posted by KimW View Post
    The development team was able to reproduce this issue with the feed you reported (and a few others) and a fix was made and tested. This will be included in the next release coming soon.
    If you've got this all sorted, great, I'll await the next release.

    If not, and you'd like more data, please let me know. I have the same issue, running BeyondPod 4.2.16, on a Pixel running Android 8.1.0, with the Jan 5 patches, and am happy to provide logs.

  8. #18
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by John_T View Post
    If you've got this all sorted, great, I'll await the next release.

    If not, and you'd like more data, please let me know. I have the same issue, running BeyondPod 4.2.16, on a Pixel running Android 8.1.0, with the Jan 5 patches, and am happy to provide logs.
    If development needs more logs I will let you know but they found the issue and made the fix and it will be pushed. If all is well with the next beta release (which we expect it to be) then that release will be pushed to production so the compatibility issues will be taken care of. Thanks for your willingness to help!

  9. #19
    Junior Member
    Join Date
    Mar 2013
    Posts
    8
    I'm consistently affected by this for a number of my podcasts.
    Let me know if I can help please.

    OnePlus5t on android 8.0

    Though the situation seems well documented and the solution obvious. Update okhttp3 which will solve the issue.
    Last edited by tilmanb; 02-20-2018 at 10:32 AM.

  10. #20
    Junior Member
    Join Date
    Mar 2013
    Posts
    8
    I can verify that the issue is fixed in the current Beta.
    If you have issues with this, try joining the beta programme.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •