currently using website v4.2.32

previously, after updating from v4.2.28 to v4.2.30 or .31 (can't remember exactly), i suddenly started having issues downloading episodes due to beyondpod throwing errors saving to or reading from /storage/emulated/0/BeyondPod directory. this is where all of my podcasts have been stored for a long time - probably a leftover from an upgrade.

i've been experiencing the "can't cast episode" problem since upgrading around ~v4.2.22 along with other oddities as well.

i decided to uninstall and see if a clean install would clear any of the issues. well, this hasn't been fun.

after restoring the install from a backup configuration, the episode download and playback works. my smartplay configuration works ("update smartplay" still only rebuilds the playlist and doesn't initiate a feed update and download of new episodes as it did prior to ~v4.2.18). i can cast episodes/sources that were failing previously. episode sync looks to be updating from the log screen. starts to look good.

now, go check feedly integration...

try adding a feed, import from Feedly -> blank screen (-> and black bar at top but no feeds in a list). hmm, usually i'll see a list of my feedly feeds and a box indicator for feeds that are missing locally. the screen is blank. no indicator of a login problem, nothing.

fine, its been awhile since i've made sure my feedly login is set correctly so i'll logout and login again and we'll see. get to login screen, select Google account credentials, aaaand, fail Oauth process since BeyondPod uses the web-tool login and google doesn't allow this any longer (since 8/2016?). is this something BeyondPod can fix since it's kinda proxying BP->feedly->google for auth?

ok, so feedly allows me to add a feedly login credential option to my account so lets do that. *scurries over to a computer to create and setup feedly local account and come back to beyondpop*

now, logging in with feedly account in beyondpop i get the same blank screen. checking the Environment Info log screen i see in the "FEEDLY INFO" section logged in is yes, login expires 3:20 pm may 12, 2018, has user is yes and can re-login is yes.

so, i'll say the feedly integration is broken. some other past issues are fixed by going through the reinstall but would really like to get feedly working again ASAP.

also, it would be very much appreciated if your devs would add these betas to google play beta option. installing betas from a download breaks the Android Auto integration which is another annoyance.