Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Beta 4.2.34 I wants it to test android auto fix, when does it go to the app store

  1. #1
    Junior Member
    Join Date
    Mar 2013
    Posts
    11

    Question Beta 4.2.34 I wants it to test android auto fix, when does it go to the app store

    You can't side load betas and have them work on android auto so I need to load betas from the app store.

    Any idea when 4.2.34 will show up there? I can't wait for this fix. BP stealing media focus on android auto would be fantastic to not have anymore.

  2. #2
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    787
    Quote Originally Posted by jjrussell View Post
    You can't side load betas and have them work on android auto so I need to load betas from the app store.

    Any idea when 4.2.34 will show up there? I can't wait for this fix. BP stealing media focus on android auto would be fantastic to not have anymore.
    Hello,

    We have submitted v4.2.34 to the Google PlayStore today so it should be available soon after it has been accepted and pushed.

  3. #3
    Junior Member
    Join Date
    Mar 2013
    Posts
    11
    I see it! Thanks, can't wait to try it out in my car.

  4. #4
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    787
    Quote Originally Posted by jjrussell View Post
    I see it! Thanks, can't wait to try it out in my car.
    Please let us know if this fix works on your end as well.

  5. #5
    Junior Member
    Join Date
    Mar 2013
    Posts
    11
    Sadly it does not. Here's what I tried.
    Environment:
    BeyondPod 4.2.34 installed from Google Play Store
    2017 Chevy Volt
    Nexus 6p
    Android 8.1.0 Build #: OPM6.171019.030.E1

    Procedure 1
    - Listening to BP in car.
    - While playing push media button to display list of apps.
    - Select Google Play Music (or any other, I tried a few)

    Result:
    - Podcast pauses
    - Google Play appears
    - BP immediately steals focus back


    Procedure 2
    - Listening to BP in car.
    - Pause BP
    - Push media button to display list of apps.
    - Select Google Play Music (or any other, I tried a few)
    - Press play on google play music

    Result:
    - Google Play appears and stays until I press play. Then BP steals focus again.


    Procedure 3
    - After procedure 1 or 2.
    - Try selecting GPM from the media list again
    - After some number of attempts it will eventually "stick" and I'll be able to play something
    - After some number of operations (select playlists, next song, pause, etc, it's not completely clear what causes it) BP will eventually steal focus back.

    I'm not sure if this is related or not but sometimes when BP steals focus back the progress bar for the episode does not appear.

    I'd love to help figure this out. Let me know if there's anything else I can try.

  6. #6
    Senior Member
    Join Date
    Aug 2012
    Posts
    236
    In Settings>Player Settings>Headset Button Actions do you have "enable headset button" disabled?

    Note that this really doesn't disable headset buttons, but I remember reading it causes issues with AA. Nice thorough procedure btw!

  7. #7
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    787
    Quote Originally Posted by jjrussell View Post
    Sadly it does not. Here's what I tried.
    Environment:
    BeyondPod 4.2.34 installed from Google Play Store
    2017 Chevy Volt
    Nexus 6p
    Android 8.1.0 Build #: OPM6.171019.030.E1

    Procedure 1
    - Listening to BP in car.
    - While playing push media button to display list of apps.
    - Select Google Play Music (or any other, I tried a few)

    Result:
    - Podcast pauses
    - Google Play appears
    - BP immediately steals focus back


    Procedure 2
    - Listening to BP in car.
    - Pause BP
    - Push media button to display list of apps.
    - Select Google Play Music (or any other, I tried a few)
    - Press play on google play music

    Result:
    - Google Play appears and stays until I press play. Then BP steals focus again.


    Procedure 3
    - After procedure 1 or 2.
    - Try selecting GPM from the media list again
    - After some number of attempts it will eventually "stick" and I'll be able to play something
    - After some number of operations (select playlists, next song, pause, etc, it's not completely clear what causes it) BP will eventually steal focus back.

    I'm not sure if this is related or not but sometimes when BP steals focus back the progress bar for the episode does not appear.

    I'd love to help figure this out. Let me know if there's anything else I can try.
    Thank you so much for your detailed feedback! I have passed this along to the developers.

  8. #8
    Junior Member
    Join Date
    Mar 2013
    Posts
    11
    Thanks a lot. I also saw that workaround in http://www.beyondpod.com/forum/showt...t=android+auto
    Haven't been in my car yet but I'll give it a try.

  9. #9
    Junior Member
    Join Date
    Mar 2012
    Posts
    16
    For me, 4.2.34 doesn't work in Android Auto any more at all -- it has completely disappeared from the AA media apps list. Comparing timestamps in the BP logs with when I start and stop AA, there is nothing, at all. There are logs from when I leave BP before starting AA, and from when I return to BP after closing AA, but absolutely nothing in between.

    I've tried rebooting my phone, I've tried the sideload trick with adb "pm install -i com.android.vending -r ...", no luck.

    4.2.32 worked fine in AA (having installed it with that sideload trick).

  10. #10
    Junior Member
    Join Date
    Jan 2013
    Posts
    4
    Quote Originally Posted by Cheetah View Post
    For me, 4.2.34 doesn't work in Android Auto any more at all -- it has completely disappeared from the AA media apps list. Comparing timestamps in the BP logs with when I start and stop AA, there is nothing, at all. There are logs from when I leave BP before starting AA, and from when I return to BP after closing AA, but absolutely nothing in between.

    I've tried rebooting my phone, I've tried the sideload trick with adb "pm install -i com.android.vending -r ...", no luck.

    4.2.32 worked fine in AA (having installed it with that sideload trick).
    I have the same problem, no BeyondPod any more in the AA app list with .34. Previous version worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •