Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: BeyondPod Slow

  1. #11
    Junior Member
    Join Date
    Jun 2015
    Posts
    9
    I’ve been having this problem for a while. I have a couple of podcasts, for example, with long episode lists, and when I open the feeds to download/play episodes the app grinds to a halt for several seconds. Manually downloading episodes, subscribing to new podcasts, or deleting feeds/episodes also cause the app to get completely bogged down for several seconds. It’s only the BP app that gets bogged down, the phone (Moto G5 on Android 7) is fine if I go into another app. I do have everything saved onto an SD card so I guess it’s possible to delays are caused by reading/writing to the card, but I’ve been using BP in this ways for years and it only became a problem a few months ago.

  2. #12
    Senior Member
    Join Date
    Aug 2012
    Posts
    227
    Deleted...forgot I responded to this thread already lol.

    It's not the SD card though, my Nexus doesn't have one and lags like crazy on updates

  3. #13

    BeyondPod Slow

    - I'm running the latest Beta version but I have experienced the following problem through maybe the past 3-5 updates.
    - Running on rooted Android.
    - I have had this app installed for maybe five years on the same phone. I uninstalled it and reinstalled it recently a few times, nothing changed. I think I deleted the directory too, not sure.

    Problem:
    BeyondPod worked great for about 4 years. Now for about a year (maybe a little less) it's so slow it's almost unusable. It's like it's "thinking" every time I go to take an action in the app. And if I click the "Download" button it Often will download another episode than the one I'm trying to download.

  4. #14
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    776
    Quote Originally Posted by RobinBFoss View Post
    4.2.34, on Galaxy S8

    BeyondPod has been running very slow for me lately, both on the beta and on the latest regular version. Sometimes there's a 10+ second delay between a touch and something happening. In addition, sometimes, when clicking the download or add to playlist button on a podcast episode, it will instead act as if I'd pressed the same button on the third or fourth episode down the list.
    Hello Robin,

    Unfortunately I am unable to reproduce your issues. Do you have a specific feed(s) that you have these issues with that we can take a look into?

  5. #15
    Junior Member
    Join Date
    Jun 2015
    Posts
    9
    Quote Originally Posted by phalkon30 View Post
    Deleted...forgot I responded to this thread already lol.

    It's not the SD card though, my Nexus doesn't have one and lags like crazy on updates
    Yes I agree about the SD card, I've always saved my podcasts onto the SD card but the app never used to lag the way it does now. It actually puts me off listening to podcasts that are affected by the lag so I will probably stop using BP soon.

  6. #16
    Junior Member
    Join Date
    Jun 2015
    Posts
    9
    I think there are a few of us experiencing the same/similar issues:

    http://www.beyondpod.com/forum/showt...ally-big-feeds

    It happens to me any time time I subscribe/unsubscribe from a feed, or whenever I try to interact with any feeds with large numbers of episodes.

  7. #17
    Thanks for the note

  8. #18
    I have this problem too. It's totally app related, not my phone.
    My issue before someone gave me this thread: http://www.beyondpod.com/forum/showt...BeyondPod-Slow
    Now I do listen to a lot of pro-America podcasts. Could that be it? Hmmmm

  9. #19
    Junior Member
    Join Date
    May 2018
    Posts
    3
    Nah, you're just paranoid, since I listen to a bunch of incredibly antiamerican podcasts and the app shits the bed for me too.

  10. #20
    This has also been affecting me. Generally it's on feeds with a large number of episodes -- for example, fetching some of the older episodes of http://www.bonfireside.chat/rss

    It seems that the UI gets confused about which episode the buttons refer to -- or possibly, the UI has lost track of what's visible in the viewport.
    This leads to me downloading or deleting the wrong episodes

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •