Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: BeyondPod BETA version 4.3.8 is now Available

  1. #1
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    843

    BeyondPod BETA version 4.3.8 is now Available

    BETA version 4.3.8 is now available. If you are not already a BETA user and would like to access the new version, you can find the apk here: http://www.beyondpod.mobi/Android/BETA/

    What is new in this version
    Fixed : Delete Played function/button not responding
    Fixed : "Mark All Played" function/button not responding
    Fixed : "Allow hiding of Read/Played Episodes" setting is not working
    Fixed : Chromecast-Remove Redundant Chromecast Notification Players
    Fixed : Double Notifications for BeyondPod
    Fixed : EpisodeSync Login States "Full"
    Fixed : ChromeCast - Cast not working correctly when at the end of episode
    Fixed : All downloaded episodes are marked as "played" during update

  2. #2
    Junior Member
    Join Date
    Jun 2019
    Posts
    12
    Hi thanks for sharing the link i will download it right now

  3. #3
    Junior Member
    Join Date
    Oct 2018
    Posts
    17
    Thank you for new beta. This version is much better than previous. I am glad that the best podcast app is back!
    Notifications are still doubling after click. But that useless second one disappears in ~5 seconds. It is not a problem.
    There is one issue - widget doesn't start play if app is not running in background. After click it is ether showing notification "loading feeds" forever, or doesn't do anything. Maybe this is only on my phone (oneplus 7, android 10). Can someone check if widget works?

  4. #4
    Junior Member
    Join Date
    Oct 2013
    Location
    UK
    Posts
    19
    Sorry guys, but Chromecast doesn't work at all anymore, after this update.
    Sometimes I get an error message in a red box saying "This episode can't be played remotely" when I try to connect to Chromecast. Other times I get a message saying "Peparing stream", even though the episode has already downloaded, then "playback error". Whatever, it just isn't possible to play anything, other than through the device's speakers, or Bluetooth. [Huawei MediaPad M5 (SHT-W09) running Android v.8]
    Will probably have to go back to the previous version, for now 😒

  5. #5
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    843
    Quote Originally Posted by Onebrow View Post
    Sorry guys, but Chromecast doesn't work at all anymore, after this update.
    Sometimes I get an error message in a red box saying "This episode can't be played remotely" when I try to connect to Chromecast. Other times I get a message saying "Peparing stream", even though the episode has already downloaded, then "playback error". Whatever, it just isn't possible to play anything, other than through the device's speakers, or Bluetooth. [Huawei MediaPad M5 (SHT-W09) running Android v.8]
    Will probably have to go back to the previous version, for now 😒
    Hello,

    We are seeing no issues on our end with Chromecast on the latest beta version 4.3.8. Chromecast issues were one of the major bugs that were fixed in this version and 4.3.7. @Onebrow, can you please send your logs (and screenshots of your error messages) so we can look for any clues as to why you are seeing issues?

    Please send your logs for development to take a look at your data for any clues:
    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue with each log so development knows what report to match your logs to.


    Is anyone else having casting issues with v4.3.8?

  6. #6
    Junior Member
    Join Date
    Oct 2018
    Posts
    17
    There are another couple of weird issues. Player is pausing when another bluetooth device disconnected. Android auto and even non-audio device like security system or obd adapter. And play button on bt headset doesn't start playing if app is not running. Battery optimization turned off.

  7. #7
    Junior Member
    Join Date
    Oct 2013
    Location
    UK
    Posts
    19
    Thanks for getting back to me KimW,
    Although I'm by no means experienced in interpreting these things, after reading your post I had a look for some clues in the log files myself, and discovered that the part of the BeyondPod log relating to the actual times when the errors occurred were not accessible anymore. However, the Android one was.
    After checking it carefully, I found a reference to the problem which was suggesting that it was possibly due to an outdated Google Services app.
    So I checked whether there were any device app updates pending and ran all the pending updates.
    This seems to have fixed the issue with regard to all the latest downloaded podcast episodes.
    There were a couple of old ones that still brought up the errors, but I listened to those on the device itself, and everything relating to Casting seems to be functioning OK now.
    So - sorry to imply that there was anything wrong with v4.3.8, but at least I've saved the devs a bit of time by fixing it myself - as well as learning something in the process!
    Thanks again

  8. #8
    Junior Member
    Join Date
    Jan 2016
    Posts
    8
    Quote Originally Posted by KimW View Post
    Is anyone else having casting issues with v4.3.8?
    I still have the problem with casting in this latest version. Logs were sent a few minutes ago.

    The problem is when there are more than 1 podcast episodes in the playlist.

    After the first episode is played, BP will iterate through all the episodes in the playlist and mark them as played. Now, if I try to click on any of the episodes, BP throws the "cannot be played remotely" error.

    The workaround is to play 1 episode (only 1 podcast in the playlist) and when it finishes, either clear the playlist and add the next episode I want to play, or I can leave the played episode then add another episode to the playlist - however, BP will mark the episode as played and I have to use the scrub bar to move the start point back to the very beginning and then I can hit play and BP will cast again.

    EDIT - In reference to Onebrow's last post - My phone is 100% up to date and this error still happens.
    Last edited by royalh13; 04-28-2020 at 12:46 PM.

  9. #9
    Junior Member
    Join Date
    May 2020
    Posts
    3
    I jumped on the BETA in hopes to resolve an issue that has plagued me for a while (issue #1) and could not find a resolution in the forums (there was another user having the exact same issue that was not able to resolve this issue as well).

    Issues:
    1. Smart Playlist will not auto update w/ new feeds. The only workaround I found was to delete the playlist and recreate it which defeats the purpose of having a "Smart" playlist.
    2. This issue is new, started once I moved over to BETA version. When using BT headphones and I finish an episode, the next episode does not auto play. (Playlist setting is "Delete and play next"). I mentioned "on BT" since while waiting for my acct to be approved, I had to recharge my BT headphones and used a wired set. On wired set, the "play next" featured worked?? This is the only time its worked since moving to the beta code and normally I only use BT headphones so this has only worked once. Will have to test more to see if there is a difference between wired and BT.
    3. When phone screen is locked, unable to hit button on headset to resume playing. It will stop the play, but not resume. Have to unlock phone and hit play on the app to get episode to resume playing.

    Currently on v4.3.8

  10. #10
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    843
    Quote Originally Posted by Rusalka68 View Post
    I jumped on the BETA in hopes to resolve an issue that has plagued me for a while (issue #1) and could not find a resolution in the forums (there was another user having the exact same issue that was not able to resolve this issue as well).

    Issues:
    1. Smart Playlist will not auto update w/ new feeds. The only workaround I found was to delete the playlist and recreate it which defeats the purpose of having a "Smart" playlist.
    2. This issue is new, started once I moved over to BETA version. When using BT headphones and I finish an episode, the next episode does not auto play. (Playlist setting is "Delete and play next"). I mentioned "on BT" since while waiting for my acct to be approved, I had to recharge my BT headphones and used a wired set. On wired set, the "play next" featured worked?? This is the only time its worked since moving to the beta code and normally I only use BT headphones so this has only worked once. Will have to test more to see if there is a difference between wired and BT.
    3. When phone screen is locked, unable to hit button on headset to resume playing. It will stop the play, but not resume. Have to unlock phone and hit play on the app to get episode to resume playing.

    Currently on v4.3.8
    Thank you for your reports. What device and version of Android are you using? Also, for Issue 1, I want to verify: you have "Auto Rebuild Smartplay" setting checked correct?
    Last edited by KimW; 05-06-2020 at 01:10 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •