Page 9 of 9 FirstFirst ... 789
Results 81 to 88 of 88

Thread: 4.2.38 pauses constantly

  1. #81
    Junior Member
    Join Date
    Aug 2012
    Posts
    5
    Quote Originally Posted by hbradlow View Post
    I am running BeyondPod 4.2.41 on a S9+ running Andorid 9. I am having this repeated pause problem. I have changed all the OS settings to ensure that Beyondpod can run in the background and not be put to sleep but it still repeatedly pauses (with Bluetooth connections - car and headphones).
    I have been using Beyondpod for many years but I shall reluctantly need to change to a new podcast player.
    Just for the record: the repeated pausing issue goes away if you turn off pause for notifications (it seems to pause every 2 minutes even though there are no notifications).
    However, I have switched to Pocketcasts as BeyondPod has too many other issues: the widget does not work, sometimes it simply won't launch (just see a constant white screen) and it does not auto launch

  2. #82
    Junior Member
    Join Date
    Jan 2020
    Posts
    1
    In researching this, it appears that Samsung phones/tablets are the issue. I have a Note 8 that was doing the same thing, and I think I figured out the issue. By default, the power options won't let it run in the background. If you go to Settings -> Device Care -> Battery -> BeyondPod. Turn off "Put app to sleep". This seems to have fixed the issue for me.

  3. #83
    Senior Member
    Join Date
    Aug 2012
    Posts
    244
    Samsung devices definitely cause more problems, but I can assure you my Pixel and Nexus phones also had this issue.

    Probably 2 bugs, one caused by Samsung, one by BeyondPod. I would guess it's something in the way BP targets old API's

  4. #84
    Junior Member
    Join Date
    Oct 2018
    Location
    Ireland
    Posts
    6
    I'm using 4.2.41 (not beta) and for me the pausing has gotten worse in the last few weeks in particular. It happens when playing through bluetooth headphones, speaker and Android Auto but not when playing through the phone's own speaker. I always download episodes, I have pause on notification setting turned off and have added BP to Apps that won't be put to sleep in power management settings.

  5. #85
    Junior Member
    Join Date
    Jan 2020
    Posts
    4
    I always had a lot of issues with Samsung devices but I never tried with the Pixel or the Nexus.

    ____________________________
    VPN Sai Mannat AnyDesk
    Last edited by burbigo1; 03-26-2020 at 03:52 PM.

  6. #86
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    825
    This seems to be an Android setting that is putting the app to sleep when the device screen is not active. You will need to change your device settings to allow BP to stay awake.

    Settings>device care>battery>beyond pod> then turn off "put app to sleep"**

    Now, the above only seems to fix the issue if you are listening directly on the device but it doesn't seem to fix the issue when listening through bluetooth, so developers have created a fix for the bluetooth issue that will be included in the next BETA release.

  7. #87
    No it's not an issue with the settings. Other apps manage to stay active without having to change the battery optimization settings. Pretty sure the app can request to stay active from the Android OS.

  8. #88
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    825
    BETA version 4.3.0 is now available on our BETA Channel.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •