Results 1 to 8 of 8

Thread: V4.2.40 crashes with Bluetooth controls

  1. #1
    Junior Member
    Join Date
    Apr 2018
    Posts
    5

    V4.2.40 crashes with Bluetooth controls

    V4.2.40
    Android: 8.0

    Since the 4.2.40 update the app will lag and crash when trying to start via my bluetooth headphones. If I go into the app on my phone and start it I have no problems and can stop it via the headphones.but trying to play again can be problematic and crash the player.

    I'm also finding that when I pause, the app shuts down entirely after a minute.

  2. #2
    Junior Member
    Join Date
    Oct 2018
    Posts
    2
    This has been happening to me as well. It is very annoying. I have even resorted to using Google podcasts, I hate it, but beyondpod is almost unusable right now.

  3. #3
    Senior Member
    Join Date
    Aug 2012
    Posts
    236
    Yeah, if I pause either through the lock screen widget or through bluetooth it won't resume if paused for longer than 3 minutes. Basically if I pause I now have to open the app again to use it, not sure what changed.

  4. #4
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    787
    Hello,

    Development is already looking into bluetooth issues to find a fix for the next release.

  5. #5
    The same behaviour is observed with the homescreen widget. It takes up to 20 seconds to start playback after hitting "play" button. Samsung galaxy s8+ with stock oreo rom. Beyondpod ver 4.2.4

  6. #6
    Junior Member
    Join Date
    Oct 2018
    Posts
    1
    Quote Originally Posted by phalkon30 View Post
    Yeah, if I pause either through the lock screen widget or through bluetooth it won't resume if paused for longer than 3 minutes. Basically if I pause I now have to open the app again to use it, not sure what changed.
    Yeah, this.
    Also happens when I use a wired earbuds (with pause/play button).
    Another issue I'm having is that sometimes when I pause, the app just crashes. When this happens, re-opening the app often takes significantly longer to load. I have to pause/start a lot at work, so this gets old REAL quick.

    I cannot stress enough how annoying this is. It's making this app almost unusable for me.

  7. #7
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    787
    This issue has been fixed in 4.2.41.

    The 4.2.41 version was released to our BP Beta channel yesterday (which can be found here: http://www.beyondpod.mobi/Android/BETA/) and it was also submitted to the Google Play Store (BETA) this morning, so it should be available on there very shortly.

    We anticipate to push this version to Production by EOD tomorrow (Friday 10/19/18).

  8. #8
    Junior Member
    Join Date
    Apr 2018
    Posts
    5
    Quote Originally Posted by KimW View Post
    This issue has been fixed in 4.2.41.

    The 4.2.41 version was released to our BP Beta channel yesterday (which can be found here: http://www.beyondpod.mobi/Android/BETA/) and it was also submitted to the Google Play Store (BETA) this morning, so it should be available on there very shortly.

    We anticipate to push this version to Production by EOD tomorrow (Friday 10/19/18).
    Sorry but it hasn't. If you try to start the app from bluetooth controls, it will crash. It will then start on the second attempt.

    They is a further issue now too. The 4.20.40 update would clear the widget from the lock screen after a few minutes of being paused.

    This doesn't happen in 4.20.41 but now, I will clear the widget from the lockscreen, and after about 5 minutes, it reappears.

    My battery monitor is also reporting a higher than normal battery drain by the app.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •