Results 1 to 7 of 7

Thread: Scheduled Updates Not Happening

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    1

    Scheduled Updates Not Happening

    Hi everyone - I'm a new user and really like BeyondPod. But I'm having an issue I hope you can help me with: I can't get scheduled updates to work.

    Apologies up front if this has already been answered and I missed it. I did search but couldn't find an answer. The closest thing I found was this, and although it doesn't seem like it's addressing my specific problem, I tried the suggestions and my problem persists.

    I have the paid version of the app.

    I have configured Settings > Feed Update Settings > Automatic Updates as follows:
    • All feeds
    • Update on Schedule: On
    • Start at: 5:00 AM
    • Repeate Every: 1 day


    However - this never seems to do anything. I have to manually click the "Refresh Feeds" button in the left-side menu to get it to search for a download new content. Thankfully, with the paid app, this can be done with one click. But it's a click that I have to remember to make when I'm on wifi - which is often not the same time I want to listen to content. As it stands right now, I sometimes find myself frustrated, "Oh crap, I forgot to refresh and download before I left this morning - now I'm not on wifi..."

    Thanks in advance for any suggestions!

  2. #2
    Junior Member
    Join Date
    Sep 2018
    Posts
    9
    Scheduled Updates haven't been working for me since I upgraded Nougat to Oreo, and Pie didn't fix it. I think it has something to do with the way newer versions of Android restrict background processes to save battery life. I have gotten around this by creating a "From - Till" profile in Tasker to trigger the Auto Update each morning.

  3. #3
    Member
    Join Date
    Aug 2012
    Location
    Illinois - US
    Posts
    42
    Have you tried to change the update schedule (like from every 1 day to every 2 days, save, and then change it back from every 2 days to every 1 day)? I ran into an issue a long time ago where if an app was force-closed at any point (or some other trigger) then Android would disable it's auto-scheduling functionality with no notification. The workaround for me at the time was to go into the app and trigger it to re-add itself to the schedule by making a change like the one I described. It may or may not help you in this particular case, but it's an easy thing to try just in it case it does work.

    I'm running Pie (Android 9) and I have two schedules set up (one daily for most of my feeds and one hourly for a couple 'news of the hour' feeds) and I'm not having any scheduling issues. I am, however, running BeyondPod v4.2.18, which is not the latest version available. I found this version to be stable.

    --James

  4. #4
    Junior Member
    Join Date
    Sep 2014
    Posts
    18
    Mine keeps wigging out. It will update fine, and then quit. If i re-work the schedule and save it is fine for a bit, and seems to quit again. I too think it has something to do with the background process/battery/wakelock or something. I am on Pie.

  5. #5
    Junior Member
    Join Date
    Oct 2015
    Posts
    8
    I was hoping someone had a solution, I've tried deleting the app and reloading, changing the schedule, and turning the schedule off and on again.

  6. #6
    Junior Member
    Join Date
    Jun 2019
    Posts
    4
    Hi, I have the same problem too and I have not found any solution.

    ___________________________________________
    ShowBox Tutuapp Mobdro
    Last edited by avensis; 08-11-2019 at 06:22 PM.

  7. #7
    Junior Member
    Join Date
    Oct 2015
    Posts
    8
    Quote Originally Posted by avensis View Post
    Hi, I have the same problem too and I have not found any solution
    Changing the app power settings as described on some of the threads did the trick. I'm updating every 4 hours now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •