Page 1 of 6 123 ... LastLast
Results 1 to 10 of 53

Thread: 4.2.30 Screen won't go to sleep while BP is active

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Location
    FI
    Posts
    4

    4.2.30 Screen won't go to sleep while BP is active

    I've noticed recently that the screen won't turn off (go to sleep) normally if Beyondpod is on. This happens in the list-of-episodes view and the player view, even while nothing is playing. In the settings views the screen turns off normally after a minute.

    I haven't found any setting that would cause this.

    This happens with Beyondpod 4.2.30, my device is HTC 10 with Android 8.0.0.

    -Edit-

    Sometimes the screen turns off right on time, sometimes not. To test this I changed the screen inactivity timeout to 15 seconds. If I now clear recent apps and open Beyondpod, it opens in the All Episodes view. The screen stays on after 15 seconds. After about 60 seconds, the screen turns off. Now I turn the screen on and am back in the All Episodes view. Now I wait 15 seconds and the screen turns off (as it should).

    So from this it looks like there's possibly some wake lock left active when BP is opened the first time after clearing recent apps, but after some time (perhaps 4 times the screen timeout) that lock ends.
    Last edited by dysii; 04-21-2018 at 12:29 PM. Reason: Further test results

  2. #2
    Junior Member
    Join Date
    Apr 2018
    Posts
    9
    I have noticed a similar behavior. I haven't tested it as thoroughly as dysii but I have noticed that sometimes the screen doesn't turn off while the podcast is playing. Most of the time it does, but not all.
    I'm running a Samsung Galaxy S9, Android 8.0.0 and BP 4.2.30

  3. #3
    Senior Member
    Join Date
    Aug 2012
    Posts
    237
    There are a few settings you may want to look at:
    -Settings>Player Settings>Automatic Pause or Resume>Screen Timeout. Is yours set to "Use Device Default"?
    -Settings>3 dot menu in upper right corner...Advanced Settings>Screen ON for WiFi (near the bottom), mine's set to "Always Off"

    I just tried putting my Nexus 6P on 8.1 BP 4.2.30 on the full screen player mode (audio paused), it shut off after the standard time. Same for when in player mode and playing a podcast, same when sitting on the "all episodes" list.

  4. #4
    Junior Member
    Join Date
    Apr 2018
    Posts
    9
    My settings are "Use Device Default" and "Always Off"

  5. #5
    Junior Member
    Join Date
    Apr 2018
    Posts
    18
    I am experiencing this as well. My screen seemingly never shuts off with BP playing, unless I hit the power button to force it off.

  6. #6
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by dysii View Post
    I've noticed recently that the screen won't turn off (go to sleep) normally if Beyondpod is on. This happens in the list-of-episodes view and the player view, even while nothing is playing. In the settings views the screen turns off normally after a minute.

    I haven't found any setting that would cause this.

    This happens with Beyondpod 4.2.30, my device is HTC 10 with Android 8.0.0.

    -Edit-

    Sometimes the screen turns off right on time, sometimes not. To test this I changed the screen inactivity timeout to 15 seconds. If I now clear recent apps and open Beyondpod, it opens in the All Episodes view. The screen stays on after 15 seconds. After about 60 seconds, the screen turns off. Now I turn the screen on and am back in the All Episodes view. Now I wait 15 seconds and the screen turns off (as it should).

    So from this it looks like there's possibly some wake lock left active when BP is opened the first time after clearing recent apps, but after some time (perhaps 4 times the screen timeout) that lock ends.
    Hello,

    I have sent you a PM to request some further information as we are unable to reproduce this on our end. The screen off timer seems to work as it should with the settings.

  7. #7
    Junior Member
    Join Date
    Apr 2018
    Posts
    1
    Same issue since 4.2.30 on my S5 neo. Quite annoying....

  8. #8
    Junior Member
    Join Date
    Apr 2018
    Posts
    18
    Quote Originally Posted by KimW View Post
    Hello,

    I have sent you a PM to request some further information as we are unable to reproduce this on our end. The screen off timer seems to work as it should with the settings.
    I'm happy to also provide whatever information you're after. This behavior is maddening and consistent for me.

  9. #9
    Junior Member
    Join Date
    Apr 2014
    Location
    FI
    Posts
    4
    Quote Originally Posted by KimW View Post
    Hello,

    I have sent you a PM to request some further information as we are unable to reproduce this on our end. The screen off timer seems to work as it should with the settings.
    I sent the logs to you as instructed.

    I checked the settings suggested by phalkon30, they were already set to "Use Device Default" and "Always Off" so they aren't the cause of this.

  10. #10
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    792
    Quote Originally Posted by lyric911 View Post
    I'm happy to also provide whatever information you're after. This behavior is maddening and consistent for me.
    A PM has been sent to you as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •