Results 1 to 10 of 10

Thread: Hanging/white screen when launching

  1. #1
    Junior Member
    Join Date
    Apr 2019
    Posts
    1

    Hanging/white screen when launching

    When launching BeyondPod, I frequently find it appears to hang or slip to a Not Responding state. Tapping the widget play button and it appears like nothing is happening, but opening the app has it just with a solid white screen.

    It can take up to 20+ seconds to launch, long enough that Android throws up the "this app is not responding" option. Sometimes the app has actually launched by this point, so the prompt is redundant, but other times I still have to hit "wait" and the app will come through.

    This can happen if it had been a long time (hours) since the last launch, but at times I've even had it happen within minutes.

    It often seems related to seeing the background feed update service running - the symbol often shows up in the notification area as soon as the app launches, even when it whitescreens.

    This happens on my device and on my partner's device, and has been for some time now.

    Version: 4.2.41 (but has been happening for months now, on prior updates)

    Devices:
    HTC U11 running Android 8.0.0 (but happened on a previous version as well)
    Samsung Galaxy S8 running Android 9 (but happened on a previous version as well)

  2. #2
    Senior Member
    Join Date
    Mar 2012
    Location
    Boston area
    Posts
    860
    My best guess is that the app has been dumped from memory, and is reloading. I keep trying to find a setting that says "NEVER remove this app from memory" but no lock so far. Yes, I've checked or unchecked everything I can find in the App settings.

  3. #3
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    789
    Quote Originally Posted by Ghostly View Post
    When launching BeyondPod, I frequently find it appears to hang or slip to a Not Responding state. Tapping the widget play button and it appears like nothing is happening, but opening the app has it just with a solid white screen.

    It can take up to 20+ seconds to launch, long enough that Android throws up the "this app is not responding" option. Sometimes the app has actually launched by this point, so the prompt is redundant, but other times I still have to hit "wait" and the app will come through.

    This can happen if it had been a long time (hours) since the last launch, but at times I've even had it happen within minutes.

    It often seems related to seeing the background feed update service running - the symbol often shows up in the notification area as soon as the app launches, even when it whitescreens.

    This happens on my device and on my partner's device, and has been for some time now.

    Version: 4.2.41 (but has been happening for months now, on prior updates)

    Devices:
    HTC U11 running Android 8.0.0 (but happened on a previous version as well)
    Samsung Galaxy S8 running Android 9 (but happened on a previous version as well)
    Hello,

    This is a known issue by development that they are working on a fix for, along with other bug fixes. Unfortunately, at this time I do not have an estimated date from them of when to expect the new release to be available.

  4. #4
    Junior Member
    Join Date
    Jul 2019
    Posts
    1
    Hi I have the same issue. I had lived with it previously on my Moto X4 but when I restored from backup to a Pixel 3 brand new phone, the issue persisted. This can happen if I pause a podcast for a brief time period and then try to resume it or if I am resuming a podcast the next morning. Here is my log. The hangs coincide with the "MediaPlayBack Service - is taking too long to load! Giving Up!" entires. The SQL database stuff I assume was starting a fresh install. I did restore from a previous backup from the moto x4 incase it's a configuration carry over issue?

    I have the pro version of the app. I love you guys i hope you can get it fixed for me!

    7/29/19 3:07:25 PM: DatabaseHelper (4.2.41) - BeyondPod database file DOES NOT EXIST!
    7/29/19 3:07:25 PM: DatabaseHelper (4.2.41) - BeyondPod database file DOES NOT EXIST!
    7/29/19 3:07:25 PM: SQLRepositoryStorage (4.2.41) - feed Database not found, Trying to load from a SQL backup: /storage/emulated/0/Android/data/mobi.beyondpod/files/BeyondPod/beyondpod.db.autobak
    7/29/19 8:42:19 PM: MediaPlaybackService (4.2.41) - MediaPlayBack Service - is taking too long to load! Giving Up!
    7/30/19 8:40:58 AM: MediaPlaybackService (4.2.41) - ******** MEDIA_ERROR_UNKNOWN, Extra:-2147483648
    7/30/19 10:20:26 AM: MediaPlaybackService (4.2.41) - MediaPlayBack Service - is taking too long to load! Giving Up!
    7/30/19 9:03:16 PM: MediaPlaybackService (4.2.41) - MediaPlayBack Service - is taking too long to load! Giving Up!
    7/30/19 9:03:16 PM: MediaPlaybackService (4.2.41) - MediaPlayBack Service - is taking too long to load! Giving Up!
    7/30/19 9:03:16 PM: MediaPlaybackService (4.2.41) - MediaPlayBack Service - is taking too long to load! Giving Up!
    7/31/19 11:40:47 AM: MediaPlaybackService (4.2.41) - MediaPlayBack Service - is taking too long to load! Giving Up!

  5. #5
    Junior Member
    Join Date
    Jun 2019
    Posts
    4
    I hope we get the fix quickly.
    Last edited by avensis; 09-03-2019 at 02:49 PM.

  6. #6
    Junior Member
    Join Date
    Jun 2013
    Posts
    3
    Quote Originally Posted by avensis View Post
    I hope we get the fix quickly
    There have been many issues (including this one) for a long time now. While it's possible it will be fixed very quickly, I would not hold my breath. Unfortunately, many users have got to the point where they're not really expecting any updates now, and have moved on to alternatives.

    I'm still holding out, but I am finding it very frustrating. If any alternative turned up with anything similar to the smart playlist in Beyondpod, I would jump on it and never look back. I'd even be willing to pay again for "BeyondPod 2" if they got everything up and running well and supported it in a timely manner.

  7. #7
    Senior Member
    Join Date
    Mar 2012
    Location
    Boston area
    Posts
    860
    I'm with you, arghness! It's the playlist generator that keeps me here.

  8. #8
    Senior Member
    Join Date
    Aug 2012
    Posts
    237
    Honestly I find Pocket Casts to be 90% there in playlist features, at least for how I use it. They call them filters, but they're just filtering into a playlist.

  9. #9
    Yeah, this is just one of so many bugs that I have just learned to live with.
    I'm really beginning to wonder if the pain of migration is really large enough to keep me from trying other podcasts.

  10. #10
    Junior Member
    Join Date
    Jul 2019
    Posts
    9
    The bugs are unbelievable and I don't know if I'll keep up with the app.

    ______________________________________
    VPN Sai Mannat AnyDesk
    Last edited by escobarrr; 09-03-2019 at 02:52 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •