Results 1 to 10 of 10

Thread: Android Auto, appears to be clearing playlist?

  1. #1
    Junior Member
    Join Date
    Nov 2014
    Posts
    17

    Cool Android Auto, appears to be clearing playlist?

    I'm on a Galaxy S9, Android 9, BeyondPod 4.2.41. I listen to podcasts in my Honda SUV with Android Auto, and except for the "getting selection error" (see other thread), it mostly works. Sometimes pauses and then resumes, but not a long or huge delay mostly.
    I'm posting today because of an odd new problem, not sure but seems it started a month or so ago.

    I've listened to some podcasts, and disconnect the phone from the car, go inside home. When I open BeyondPod later, all my playlist is removed. There should have been items there I didn't listen to.
    I use a cache cleaning app, AppMgr III, v. 4.93, so I wonder if when I clear cache(s), usually daily, I might be removing the playlist somehow. Is it stored in cache?
    I tried setting cache cleaning for BeyondPod to ignore list, so it doesn't clean the cache on that app, so I'll see if that helps.

    I've checked my settings, and nothing there should be doing this.
    Any tips or anyone else experiencing this, too?

    Best,
    DrWeb

  2. #2
    Senior Member
    Join Date
    Aug 2012
    Posts
    249
    That's a problem I've never had/seen. Why use the cache clearing app at all? It's definitely not benefiting a modern operating system for performance, and I doubt it's bringing any meaningful storage back to your phone since it will just have to spend CPU cycles creating the caches again and filling that space back up.

    Try uninstalling it for a while, you'll both prove that it was/was not the issue and also see if you can really tell the diference on your phone without it.

  3. #3
    Junior Member
    Join Date
    Nov 2014
    Posts
    17
    Quote Originally Posted by phalkon30 View Post
    That's a problem I've never had/seen. Why use the cache clearing app at all? It's definitely not benefiting a modern operating system for performance, and I doubt it's bringing any meaningful storage back to your phone since it will just have to spend CPU cycles creating the caches again and filling that space back up.

    Try uninstalling it for a while, you'll both prove that it was/was not the issue and also see if you can really tell the diference on your phone without it.
    Good advice.. I will try that, thank you.. I removed a link to clear cache, and seems better. But, you make a good point, why even have that anymore?

    Best,
    DrWeb

  4. #4
    Senior Member
    Join Date
    Aug 2012
    Posts
    249
    Let us know how it goes!

  5. #5
    Junior Member
    Join Date
    Nov 2014
    Posts
    17
    The tweak in settings for the app did the trick; I marked to IGNORE the cache in the AprMgrIII app, and no problems with missing or losing the playlist. Hurray!!!

    Thanks for the help!
    DrWeb

  6. #6
    Junior Member
    Join Date
    Nov 2014
    Posts
    17
    Update: 3/2/2020
    Again, same thing, the playlist "disappeared" (well, I think it left one or two items) suddenly when I looked at the app, was going to listen to one. No reason. I closed the app, re-open it, still no playlist. Very annoying, the podcasts are STILL there, in the feed list they are numbered with an episode downloaded, but they are no longer in the playlist. It's like something in the code TURNED OFF the switch that added them or kept them on the playlist. Odd and annoying.

    And on another note (I'll try and find the old thread), the failure on Android Auto grows worse, and still a pain in the rear. I try and listen in the car (2017 Honda SUV) and it spins and can't connect or show categories and feeds. So, I use menu, pick either Audible or Smart Audio Player, play 5 seconds of play sound, then stop, and when I hit BeyondPod again, it loads, and I can play my podcasts. So annoying.. what bugs me is WHY do the other audio apps work and not BeyondPod? They must have SOME audio or other code that WORKS with Android Auto perfectly. I don't know why only BP has this problem.
    Thanks,
    DrWeb
    Right now, I'm on Galaxy S9, with the Android 10 UI 2.0 installed (Sprint). Running the latest release version, not the beta.

  7. #7
    Junior Member
    Join Date
    Jun 2019
    Posts
    14
    Hi, did you find a solution?

    __________________________________
    TweakBox word counter Tutuapp
    Last edited by avensis; 05-08-2020 at 02:53 PM.

  8. #8
    Junior Member
    Join Date
    Nov 2014
    Posts
    17
    Update: 4/5/2020

    Again, same thing, the playlist "disappeared" (well, I think it left one or two items) suddenly when I looked at the app, was going to listen to one. No reason. I closed the app, re-open it, still no playlist. Very annoying, the podcasts are STILL there, in the feed list they are numbered with an episode downloaded, but they are no longer in the playlist. It's like something in the code TURNED OFF the switch that added them or kept them on the playlist. Odd and annoying.
    Yesterday, had 11 items in playlist. Drove somewhere, listened to 3. Got home, opened app at home on phone, only 2 items left on playlist. Makes no sense...
    Still a problem...

    Thanks,
    DrWeb
    Right now, I'm on Galaxy S9, with the Android 10 UI 2.0 installed (Sprint). Running the latest release version, not the beta.

  9. #9
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    878
    Quote Originally Posted by drweb View Post
    Update: 4/5/2020

    Again, same thing, the playlist "disappeared" (well, I think it left one or two items) suddenly when I looked at the app, was going to listen to one. No reason. I closed the app, re-open it, still no playlist. Very annoying, the podcasts are STILL there, in the feed list they are numbered with an episode downloaded, but they are no longer in the playlist. It's like something in the code TURNED OFF the switch that added them or kept them on the playlist. Odd and annoying.
    Yesterday, had 11 items in playlist. Drove somewhere, listened to 3. Got home, opened app at home on phone, only 2 items left on playlist. Makes no sense...
    Still a problem...

    Thanks,
    DrWeb
    Right now, I'm on Galaxy S9, with the Android 10 UI 2.0 installed (Sprint). Running the latest release version, not the beta.
    Please send your logs for development to take a look at your data for any clues:
    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue with each log so development knows what report to match your logs to.

  10. #10
    Junior Member
    Join Date
    Nov 2014
    Posts
    17
    Quote Originally Posted by blackiyto View Post
    Let us know how it goes!
    No change.. still happens...
    Best,
    DrWeb

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •