Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: BeyondPod BETA version 4.3.8 is now Available

  1. #11
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    853
    Quote Originally Posted by royalh13 View Post
    I still have the problem with casting in this latest version. Logs were sent a few minutes ago.

    The problem is when there are more than 1 podcast episodes in the playlist.

    After the first episode is played, BP will iterate through all the episodes in the playlist and mark them as played. Now, if I try to click on any of the episodes, BP throws the "cannot be played remotely" error.

    The workaround is to play 1 episode (only 1 podcast in the playlist) and when it finishes, either clear the playlist and add the next episode I want to play, or I can leave the played episode then add another episode to the playlist - however, BP will mark the episode as played and I have to use the scrub bar to move the start point back to the very beginning and then I can hit play and BP will cast again.

    EDIT - In reference to Onebrow's last post - My phone is 100% up to date and this error still happens.
    Can you please provide the titles of the feeds you are casting episodes from when you run into this issue?

  2. #12
    Junior Member
    Join Date
    May 2020
    Posts
    3
    Quote Originally Posted by KimW View Post
    Thank you for your reports. What device and version of Android are you using? Also, for Issue 1, I want to verify: you have "Auto Rebuild Smartplay" setting checked correct?
    I am on a Samsung Note 8.

    Yes, "Auto Rebuild Smartplay" is checked. I have tried unchecking rebooting phone, rechecking it. Only thing that works is building a new SmartPlay list. Wonder if this is related to always having a BeyondPod notification that won't go away that says something along the line of "preparing to download". Its gone now that I rebuilt the playlist a few hours ago.

    Update on Issue #2, it appears to be no difference between BT or wired. And when it will "play next" is random, sometimes it will play the next episode, sometimes not. Still trying to see if there is pattern of when it will or wont play the next episode.

  3. #13
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    853
    Quote Originally Posted by Rusalka68 View Post
    I am on a Samsung Note 8.

    Yes, "Auto Rebuild Smartplay" is checked. I have tried unchecking rebooting phone, rechecking it. Only thing that works is building a new SmartPlay list. Wonder if this is related to always having a BeyondPod notification that won't go away that says something along the line of "preparing to download". Its gone now that I rebuilt the playlist a few hours ago.

    Update on Issue #2, it appears to be no difference between BT or wired. And when it will "play next" is random, sometimes it will play the next episode, sometimes not. Still trying to see if there is pattern of when it will or wont play the next episode.
    Thank you for providing more details. I will get this additional information passed over to the development team.

  4. #14
    Junior Member
    Join Date
    May 2020
    Posts
    2
    Hello,

    I am now on beta 4.3.8 with android 9 on a Xiaomi rednote 5.

    Every so often, when I reach the end of an audio podcast, BeyondPod will just stall and stay idle, instead of deleting played episode and starting the next. This appears to be random, it is not dependent on the feed nor the episode's length, it will sometimes happen for 4 episodes in a row and sometimes I can go through an entire day without trouble. Although the problem is older than this version, the beta has not resolved it.

    Thank you for your support and for the great work.

  5. #15
    Junior Member
    Join Date
    May 2020
    Posts
    3
    KimW,

    Update regarding issue #1 SmartPlay list. So its looking more like the issue is not with the SmartPlay list but with feeds not auto updating. Automatic Updates "Update on Schedule" is on and set for 4:25 AM, repeat every 1 Days. I noticed today that it hadn't run in 2 days, when I forced the update, SmartPlay also updated.

  6. #16
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    853
    Quote Originally Posted by Roger_wilco View Post
    Hello,

    I am now on beta 4.3.8 with android 9 on a Xiaomi rednote 5.

    Every so often, when I reach the end of an audio podcast, BeyondPod will just stall and stay idle, instead of deleting played episode and starting the next. This appears to be random, it is not dependent on the feed nor the episode's length, it will sometimes happen for 4 episodes in a row and sometimes I can go through an entire day without trouble. Although the problem is older than this version, the beta has not resolved it.

    Thank you for your support and for the great work.
    Hello,

    Could you please send your logs so development can take look?

    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue with each log so development knows what report to match your logs to.

  7. #17
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    853
    Quote Originally Posted by Rusalka68 View Post
    KimW,

    Update regarding issue #1 SmartPlay list. So its looking more like the issue is not with the SmartPlay list but with feeds not auto updating. Automatic Updates "Update on Schedule" is on and set for 4:25 AM, repeat every 1 Days. I noticed today that it hadn't run in 2 days, when I forced the update, SmartPlay also updated.
    Thank you for the update Rusalka68. We have had other reports of SmartPlay not updating and development is currently working to find the issue and a fix, however we have not seen issues with Auto-Updates not running. I checked the logs for 3 different devices and the Auto-Update ran as expected. If you could send your logs, that would be helpful to compare yours with the other users who have reported issues with SmartPlay. Thank you!

    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue with each log so development knows what report to match your logs to.

  8. #18
    Junior Member
    Join Date
    Feb 2014
    Posts
    5
    I'm on 4.3.8 right now. Each time I edit a random podcast (for instance: changing it's category), the one that's playing at the same times stops playing and than I can start that podcast twice. I will try to give an example: I started a podcast. At 5 minutes listening to the podcast I do edit one of my other podcasts. The podcast that was playing stops playing. The buttons within the interface show that the podcast is still playing. Clicking on the button will change the button to a state that the podcast is paused, but instead, the podcast starts playing from minute 5. Let's say I listen another 5 minutes. At minute 10 I click on the button (that says the podcast is paused) again, because I want to pause the podcast. At that moment, the podcast won't pause, but it starts playing another instance of the same podcast starting at minute 5. So now I hear the same podcast twice, one that is playing on minute 10, one that is playing on minute 5. The only way to stop the behavior is to force close the program.

  9. #19
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    853
    Quote Originally Posted by veelineen View Post
    I'm on 4.3.8 right now. Each time I edit a random podcast (for instance: changing it's category), the one that's playing at the same times stops playing and than I can start that podcast twice. I will try to give an example: I started a podcast. At 5 minutes listening to the podcast I do edit one of my other podcasts. The podcast that was playing stops playing. The buttons within the interface show that the podcast is still playing. Clicking on the button will change the button to a state that the podcast is paused, but instead, the podcast starts playing from minute 5. Let's say I listen another 5 minutes. At minute 10 I click on the button (that says the podcast is paused) again, because I want to pause the podcast. At that moment, the podcast won't pause, but it starts playing another instance of the same podcast starting at minute 5. So now I hear the same podcast twice, one that is playing on minute 10, one that is playing on minute 5. The only way to stop the behavior is to force close the program.
    Hello,
    Please send your details and logs (and any videos/screenshots if possible) so the development team can take a further look.

    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue with each log so development knows what report to match your logs to.

  10. #20
    Junior Member
    Join Date
    May 2020
    Posts
    1
    A few issues with the 4.3.8 beta release I've noticed:
    * As with @Roger_wilco, I too get BeyondPod hanging at the end of some podcasts and not deleting and continuing to the next one in the list.
    * When I pause the display to take a call for a meeting, about 20 minutes later it will start playing again. It seems right at 20 minutes too.
    * Some times when opening BeyondPod it starts (clears the screen), but then hangs on the blank screen. Force killing it, or waiting a few minutes for Android to figure out it has hung kills it too. Running it again seems to always work.
    * I have the 4x1 widget on my main screen. If I haven't started BP it doesn't even fire up the app. If I start BP then move back to the home screen, the widget works.

    My phone is a Google Pixel 4 with Android 10, update May 5, 2020 (latest currently available).

    I submitted the Android and BeyondPod logs - the "pause" issue just occurred around 3PM US Central (~15 minutes ago), so hopefully that information is helpful there. I can't remember if the hanging thing happened this morning or last night.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •