I have been using BeyondPod for several years and paid for the upgrade shortly after I started using it.

Currently, I am using version 4.3.8
This is on a Google Pixel 2, running Android 10.

So, first of all, this is absolutely my favorite podcast player. I have all my pods loaded and set-up organized the way I want it and it has worked great until recently.

In the past few months, the widget has stopped responding. If I tap the play button nothing happens. However, if I tap above the play button, where the track info and cover art is located, it will open the player and I can operate it from there.

Once I open the player, the widget will work and respond appropriately for a few minutes, but then the play/pause, FWD/Rev and skip buttons do no respond.

I have also noticed that after a few minutes on pause, the notification player will leave the notification tray and I am unable to resume play with the headset button. I then have to re-open the play to resume play again (because by that time, the widget is back to not responding).

I tried to do a search of the forums, but didn't find anything similar.
Is this a known issue, or is something extra funky going on.

Thank you!