Results 1 to 8 of 8

Thread: Some Episodes Failed to Download

  1. #1
    Junior Member
    Join Date
    Jan 2021
    Location
    San Diego, CA USA
    Posts
    4

    Some Episodes Failed to Download

    "Some Episodes Failed To Download. Please try again later." Started happening on January 3, 2021. It does this on every feed except one, but on that one it took such an extremely long time to download, that I'm sure it's broken. I've been using Beyondpod, for so long, I don't remember when I started, perhaps in the Galaxy S3 days. For the past 2-3 years I've using it on my Pixel 3. I even tried uninstalling and installing it again from the Play Store. Log says failed to connect to local host after 20 seconds. (Which I already knew.) I'm able to use my computer to manually download mp3 files, load them on to the phone via usb, and add the mp3 to a "virtual folder", which shows up in the feed list. The normal manual download via the Beyondpod app just produces that error.
    Last edited by Ronc; 01-08-2021 at 06:41 PM.

  2. #2
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    933
    Hello,

    Can you please send your logs for us to take a look at? We would like to see the Android Log, BeyondPod Log and the latest Update Log that shows the errors please.

    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" and "Update Log" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue or refer to your forum post with each log so development knows what report to match your logs to.

  3. #3
    Junior Member
    Join Date
    Jan 2021
    Location
    San Diego, CA USA
    Posts
    4
    Quote Originally Posted by KimW View Post
    Hello,

    Can you please send your logs for us to take a look at? We would like to see the Android Log, BeyondPod Log and the latest Update Log that shows the errors please.

    To send log files, go to BP Settings>> Menu Overflow (3 dot icon in the top right corner) >> View Logs >> Choose the logs "Android" and "BeyondPod" and "Update Log" (these steps will need to be taken for each log separately) >> Menu overflow >> Email.

    Please make sure to include a brief description of your issue or refer to your forum post with each log so development knows what report to match your logs to.
    Sent all 3 logs in separate emails with "Ronc Forum Post" added to the title.

  4. #4
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    933
    Great, thank you for sending those! Communication will continue in reply to those log emails.

  5. #5
    Junior Member
    Join Date
    Jan 2021
    Location
    San Diego, CA USA
    Posts
    4
    Quote Originally Posted by KimW View Post
    Great, thank you for sending those! Communication will continue in reply to those log emails.
    Re: [QUOTE (from BP email)] = "Thank you for providing your logs as requested. Please use the below link to download BeyondPod v4.3.31 to see if this fixes your download issues. This version has some core fixes included in it and we are not seeing issues with the feeds shown in your logs in this version, that you are seeing in v4.3.28. BeyondPod v4.3.31 (link below) has not been released to the public yet (will be soon) but it has been given to a handful of users who reported similar issues and this version has fixed their issues..." [/QUOTE]

    Before downloading the beta version, I discovered I could temporarily fix the problem by changing the Private DNS host to "1dot1dot1dot1.cloudflare-dns.com". When the problem came back the next day, I turned Private DNS Mode off. It's almost like AT&T saw that my phone was using a private DNS after a day or two, so they stopped letting my traffic through except at very slow speeds. I never even noticed the private DNS mode until recently, so I'm thinking Google slipped it in at the beginning of the year. I first discovered the existence of this mode when I did a speed test at Broadbandreports.com. They said my phone couldn't connect to any of their servers, providing an obscure error message about "private dns", among other possibilities. They suggested I could run the test using numerical hosts, to bypass the DNS issue, and provided a convenient button to push to run the test that way, which worked properly, not only for their test site but for my subsequent podcast downloads later that day, even after a reboot. Their website fixed my phone! But, as I said, only temporarily, which is why I'll continue to try it with Private DNS turned off. That is, the old version, not the beta.
    Last edited by Ronc; 01-12-2021 at 07:12 PM.

  6. #6
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    933
    Quote Originally Posted by Ronc View Post
    Re: "Thank you for providing your logs as requested. Please use the below link to download BeyondPod v4.3.31 to see if this fixes your download issues. This version has some core fixes included in it and we are not seeing issues with the feeds shown in your logs in this version, that you are seeing in v4.3.28. BeyondPod v4.3.31 (link below) has not been released to the public yet (will be soon) but it has been given to a handful of users who reported similar issues and this version has fixed their issues..."

    Before downloading the beta version, I discovered I could temporarily fix the problem by changing the Private DNS host to "1dot1dot1dot1.cloudflare-dns.com". When the problem came back the next day, I turned Private DNS Mode off. It's almost like AT&T saw that my phone was using a private DNS after a day or two, so they stopped letting my traffic through except at very slow speeds. I never even noticed the private DNS mode until recently, so I'm thinking Google slipped it in at the beginning of the year. I first discovered the existence of this mode when I did a speed test at Broadbandreports.com. They said my phone couldn't connect to any of their servers, providing an obscure error message about "private dns", among other possibilities. They suggested I could run the test using numerical hosts, to bypass the DNS issue, and provided a convenient button to push to run the test that way, which worked properly, not only for their test site but for my subsequent podcast downloads later that day, even after a reboot. Their website fixed my phone! But, as I said, only temporarily, which is why I'll continue to try it with Private DNS turned off.
    Are you still having issues with failed downloads using BeyondPod version 4.3.31? You said you discovered the temporary fix of turning off Private DNS on your device before you downloaded v4.3.31 and that worked for you briefly, so I'm just curious if you are still seeing the issue with v4.3.31 when you have the Private DNS turned on? I'm assuming the issue is still occurring if the problem seems to be caused by this Android Feature/Setting but I want to collect as much information as I can. Thank you!

  7. #7
    Junior Member
    Join Date
    Jan 2021
    Location
    San Diego, CA USA
    Posts
    4
    Quote Originally Posted by KimW View Post
    Are you still having issues with failed downloads using BeyondPod version 4.3.31? You said you discovered the temporary fix of turning off Private DNS on your device before you downloaded v4.3.31 and that worked for you briefly, so I'm just curious if you are still seeing the issue with v4.3.31 when you have the Private DNS turned on? I'm assuming the issue is still occurring if the problem seems to be caused by this Android Feature/Setting but I want to collect as much information as I can. Thank you!
    When I said "temporarily", I meant when I changed from the original DNS provider to Cloudflare. Turning off the feature completely may have fixed it permanently. I haven't yet downloaded the beta since I want to see if the problem comes back with Private DNS off. The old version works normally now.
    Last edited by Ronc; 01-12-2021 at 07:10 PM.

  8. #8
    BeyondPod Team
    Join Date
    Mar 2017
    Location
    US
    Posts
    933
    Okay. Thank you for the clarification.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •